summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml2
-rw-r--r--docs/python3.rst2
-rw-r--r--setup.py15
-rw-r--r--tox.ini6
4 files changed, 16 insertions, 9 deletions
diff --git a/.travis.yml b/.travis.yml
index a592c8f..aed7083 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,9 +1,7 @@
sudo: false
language: python
python:
- - "2.6"
- "2.7"
- - "3.3"
- "3.4"
- "3.5"
- "3.6"
diff --git a/docs/python3.rst b/docs/python3.rst
index cc84a05..65e1b50 100644
--- a/docs/python3.rst
+++ b/docs/python3.rst
@@ -6,7 +6,7 @@ Python 3 Support
Click supports Python 3, but like all other command line utility libraries,
it suffers from the Unicode text model in Python 3. All examples in the
documentation were written so that they could run on both Python 2.x and
-Python 3.3 or higher.
+Python 3.4 or higher.
At the moment, it is strongly recommended to use Python 2 for Click
utilities unless Python 3 is a hard requirement.
diff --git a/setup.py b/setup.py
index 79f7f66..bc49da0 100644
--- a/setup.py
+++ b/setup.py
@@ -13,16 +13,27 @@ with open('click/__init__.py', 'rb') as f:
setup(
name='click',
+ version=version,
+ url='https://www.palletsprojects.com/p/click/',
author='Armin Ronacher',
author_email='armin.ronacher@active-4.com',
- version=version,
- url='http://github.com/pallets/click',
+ maintainer='Pallets team',
+ maintainer_email='contact@palletsprojects.com',
packages=['click'],
description='A simple wrapper around optparse for '
'powerful command line utilities.',
+ license='BSD',
classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
'License :: OSI Approved :: BSD License',
+ 'Operating System :: OS Independent'
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
],
)
diff --git a/tox.ini b/tox.ini
index 9f72ab8..af7bf98 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,14 +1,12 @@
[tox]
-envlist = py{26,27,33,34,35,36,py}
+envlist = py27,py34,py35,py36,pypy
[testenv]
passenv = LANG
commands = {env:TEST_RUNNER:pytest} {posargs}
deps =
- {env:_CLICK_TEST_PYTEST_DEP:pytest}
+ pytest
colorama: colorama
coverage: coverage
setenv =
coverage: TEST_RUNNER=coverage run -m pytest
- # pytest 3.3+ does not support Python 2.6 and 3.3 anymore.
- py26,py33: _CLICK_TEST_PYTEST_DEP=pytest<3.3