summaryrefslogtreecommitdiff
path: root/demoapp
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2012-04-28 19:11:05 -0400
committerDoug Hellmann <doug.hellmann@dreamhost.com>2012-04-28 19:37:23 -0400
commit0fba7287795eba5a1d7bd6e5d30ef6ce0e91efdb (patch)
tree8a32fb13ee013dd78fae12b2c7ece62ef5a634b5 /demoapp
parentf53c84dbe992941399a9a0f7caefdd98c43de0ad (diff)
downloadcliff-0fba7287795eba5a1d7bd6e5d30ef6ce0e91efdb.tar.gz
simplify packaging file for demo app
Diffstat (limited to 'demoapp')
-rw-r--r--demoapp/setup.py101
1 files changed, 0 insertions, 101 deletions
diff --git a/demoapp/setup.py b/demoapp/setup.py
index 83c957e..46d0d12 100644
--- a/demoapp/setup.py
+++ b/demoapp/setup.py
@@ -21,100 +21,6 @@ try:
except IOError:
long_description = ''
-##############################################################################
-# find_package_data is an Ian Bicking creation.
-
-# Provided as an attribute, so you can append to these instead
-# of replicating them:
-standard_exclude = ('*.py', '*.pyc', '*~', '.*', '*.bak', '*.swp*')
-standard_exclude_directories = ('.*', 'CVS', '_darcs', './build',
- './dist', 'EGG-INFO', '*.egg-info')
-
-
-def find_package_data(
- where='.', package='',
- exclude=standard_exclude,
- exclude_directories=standard_exclude_directories,
- only_in_packages=True,
- show_ignored=False):
- """
- Return a dictionary suitable for use in ``package_data``
- in a distutils ``setup.py`` file.
-
- The dictionary looks like::
-
- {'package': [files]}
-
- Where ``files`` is a list of all the files in that package that
- don't match anything in ``exclude``.
-
- If ``only_in_packages`` is true, then top-level directories that
- are not packages won't be included (but directories under packages
- will).
-
- Directories matching any pattern in ``exclude_directories`` will
- be ignored; by default directories with leading ``.``, ``CVS``,
- and ``_darcs`` will be ignored.
-
- If ``show_ignored`` is true, then all the files that aren't
- included in package data are shown on stderr (for debugging
- purposes).
-
- Note patterns use wildcards, or can be exact paths (including
- leading ``./``), and all searching is case-insensitive.
-
- This function is by Ian Bicking.
- """
-
- out = {}
- stack = [(convert_path(where), '', package, only_in_packages)]
- while stack:
- where, prefix, package, only_in_packages = stack.pop(0)
- for name in os.listdir(where):
- fn = os.path.join(where, name)
- if os.path.isdir(fn):
- bad_name = False
- for pattern in exclude_directories:
- if (fnmatchcase(name, pattern)
- or fn.lower() == pattern.lower()):
- bad_name = True
- if show_ignored:
- print >> sys.stderr, (
- "Directory %s ignored by pattern %s"
- % (fn, pattern))
- break
- if bad_name:
- continue
- if os.path.isfile(os.path.join(fn, '__init__.py')):
- if not package:
- new_package = name
- else:
- new_package = package + '.' + name
- stack.append((fn, '', new_package, False))
- else:
- stack.append((fn,
- prefix + name + '/',
- package,
- only_in_packages))
- elif package or not only_in_packages:
- # is a file
- bad_name = False
- for pattern in exclude:
- if (fnmatchcase(name, pattern)
- or fn.lower() == pattern.lower()):
- bad_name = True
- if show_ignored:
- print >> sys.stderr, (
- "File %s ignored by pattern %s"
- % (fn, pattern))
- break
- if bad_name:
- continue
- out.setdefault(package, []).append(prefix + name)
- return out
-##############################################################################
-
-
setup(
name=PROJECT,
version=VERSION,
@@ -149,13 +55,6 @@ setup(
namespace_packages=[],
packages=find_packages(),
include_package_data=True,
- # Scan the input for package information
- # to grab any data files (text, images, etc.)
- # associated with sub-packages.
- package_data=find_package_data(PROJECT,
- package=PROJECT,
- only_in_packages=False,
- ),
entry_points={
'console_scripts': [