summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Ganssle <paul@ganssle.io>2019-11-03 01:31:10 -0400
committerGitHub <noreply@github.com>2019-11-03 01:31:10 -0400
commitfc9b1625ebc729f01e449879b6b140abd12ae621 (patch)
tree8d765931524e14090c1a3ba1c77462578effad4c
parent5fdbdbb79680a15abb24c5a0e61dd280507b13b8 (diff)
parent4ccc8bb3560988c8414ab499a9578ce8a313a135 (diff)
downloaddateutil-git-fc9b1625ebc729f01e449879b6b140abd12ae621.tar.gz
Merge pull request #974 from pganssle/release_2.8.12.8.1
Prepare 2.8.1 release
-rw-r--r--NEWS80
-rw-r--r--changelog.d/735.misc.rst2
-rw-r--r--changelog.d/871.misc.rst3
-rw-r--r--changelog.d/875.misc.rst3
-rw-r--r--changelog.d/876.misc.rst2
-rw-r--r--changelog.d/879.misc.rst3
-rw-r--r--changelog.d/881.bugfix.rst3
-rw-r--r--changelog.d/882.misc.rst2
-rw-r--r--changelog.d/890.misc.rst2
-rw-r--r--changelog.d/891.bugfix.rst4
-rw-r--r--changelog.d/891.misc.rst2
-rw-r--r--changelog.d/892.misc.rst2
-rw-r--r--changelog.d/893.misc.rst2
-rw-r--r--changelog.d/894.misc.rst2
-rw-r--r--changelog.d/910.bugfix.rst2
-rw-r--r--changelog.d/915.misc.rst1
-rw-r--r--changelog.d/916.misc.rst3
-rw-r--r--changelog.d/928.bugfix.rst1
-rw-r--r--changelog.d/934.misc.rst1
-rw-r--r--changelog.d/935.misc.rst1
-rw-r--r--changelog.d/950.bugfix.rst1
-rw-r--r--changelog.d/952.misc.rst1
-rw-r--r--changelog.d/961.data.rst1
-rw-r--r--changelog.d/962.misc.rst1
-rw-r--r--changelog.d/963.bugfix.rst2
-rw-r--r--changelog.d/966.misc.rst2
-rw-r--r--changelog.d/969.misc.rst1
-rw-r--r--changelog.d/970.misc.rst1
-rw-r--r--changelog.d/971.misc.rst1
-rw-r--r--changelog.d/973.bugfix.rst1
30 files changed, 80 insertions, 53 deletions
diff --git a/NEWS b/NEWS
index afc4e03..293f0ca 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,83 @@
+Version 2.8.1 (2019-11-03)
+==========================
+
+Data updates
+------------
+
+- Updated tzdata version to 2019c.
+
+
+Bugfixes
+--------
+
+- Fixed a race condition in the ``tzoffset`` and ``tzstr`` "strong" caches on
+ Python 2.7. Reported by @kainjow (gh issue #901).
+- Parsing errors will now raise ``ParserError``, a subclass of ``ValueError``,
+ which has a nicer string representation. Patch by @gfyoung (gh pr #881).
+- ``parser.parse`` will now raise ``TypeError`` when ``tzinfos`` is passed a
+ type that cannot be interpreted as a time zone. Prior to this change, it
+ would raise an ``UnboundLocalError`` instead. Patch by @jbrockmendel (gh pr
+ #891).
+- Changed error message raised when when passing a ``bytes`` object as the time
+ zone name to gettz in Python 3. Reported and fixed by @labrys () (gh issue
+ #927, gh pr #935).
+- Changed compatibility logic to support a potential Python 4.0 release. Patch
+ by Hugo van Kemenade (gh pr #950).
+- Updated many modules to use ``tz.UTC`` in favor of ``tz.tzutc()`` internally,
+ to avoid an unnecessary function call. (gh pr #910).
+- Fixed issue where ``dateutil.tz`` was using a backported version of
+ ``contextlib.nullcontext`` even in Python 3.7 due to a malformed import
+ statement. (gh pr #963).
+
+
+Tests
+-----
+
+- Switched from using assertWarns to using pytest.warns in the test suite. (gh
+ pr #969).
+- Fix typo in setup.cfg causing PendingDeprecationWarning to not be explicitly
+ specified as an error in the warnings filter. (gh pr #966)
+- Fixed issue where ``test_tzlocal_offset_equal`` would fail in certain
+ environments (such as FreeBSD) due to an invalid assumption about what time
+ zone names are provided. Reported and fixed by Kubilay Kocak (gh issue #918,
+ pr #928).
+- Fixed a minor bug in ``test_isoparser`` related to ``bytes``/``str``
+ handling. Fixed by @fhuang5 (gh issue #776, gh pr #879).
+- Explicitly listed all markers used in the pytest configuration. (gh pr #915)
+- Extensive improvements to the parser test suite, including the adoption of
+ ``pytest``-style tests and the addition of parametrization of several test
+ cases. Patches by @jbrockmendel (gh prs #735, #890, #892, #894).
+- Added tests for tzinfos input types. Patch by @jbrockmendel (gh pr #891).
+- Fixed failure of test suite when changing the TZ variable is forbidden.
+ Patch by @shadchin (gh pr #893).
+- Pinned all test dependencies on Python 3.3. (gh prs #934, #962)
+
+
+Documentation changes
+---------------------
+
+- Fixed many misspellings, typos and styling errors in the comments and
+ documentation. Patch by Hugo van Kemenade (gh pr #952).
+
+
+Misc
+----
+
+- Added Python 3.8 to the trove classifiers. (gh pr #970)
+- Moved as many keys from ``setup.py`` to ``setup.cfg`` as possible. Fixed by
+ @FakeNameSE, @aquinlan82, @jachen20, and @gurgenz221 (gh issue #871, gh pr
+ #880).
+- Reorganized ``parser`` methods by functionality. Patch by @jbrockmendel (gh
+ pr #882).
+- Switched ``release.py`` over to using ``pep517.build`` for creating releases,
+ rather than direct invocations of ``setup.py``. Fixed by @smeng10 (gh issue
+ #869, gh pr #875).
+- Added a "build" environment into the tox configuration, to handle dependency
+ management when making releases. Fixed by @smeng10 (gh issue #870,r
+ gh pr #876).
+- GH #916, GH #971
+
+
Version 2.8.0 (2019-02-04)
==========================
diff --git a/changelog.d/735.misc.rst b/changelog.d/735.misc.rst
deleted file mode 100644
index 0d8d7da..0000000
--- a/changelog.d/735.misc.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Converted many tests in ``test_parser`` over to using ``pytest`` style tests.
-Patch by @jbrockmendel (gh pr #735)
diff --git a/changelog.d/871.misc.rst b/changelog.d/871.misc.rst
deleted file mode 100644
index dd786c3..0000000
--- a/changelog.d/871.misc.rst
+++ /dev/null
@@ -1,3 +0,0 @@
-Moved as many keys from ``setup.py`` to ``setup.cfg`` as possible.
-Fixed by @FakeNameSE, @aquinlan82, @jachen20, and @gurgenz221
-(gh issue #871, gh pr #880)
diff --git a/changelog.d/875.misc.rst b/changelog.d/875.misc.rst
deleted file mode 100644
index ee06776..0000000
--- a/changelog.d/875.misc.rst
+++ /dev/null
@@ -1,3 +0,0 @@
-Switched release.py over to using ``pep517.build`` for creating releases,
-rather than direct invocations of ``setup.py``.
-Fixed by @smeng10 (gh issue #869, gh pr #875)
diff --git a/changelog.d/876.misc.rst b/changelog.d/876.misc.rst
deleted file mode 100644
index 243a407..0000000
--- a/changelog.d/876.misc.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Added a "build" environment into the tox configuration, to handle dependency
-management when making releases. Fixed by @smeng10 (gh issue #870 gh pr #876)
diff --git a/changelog.d/879.misc.rst b/changelog.d/879.misc.rst
deleted file mode 100644
index 7696233..0000000
--- a/changelog.d/879.misc.rst
+++ /dev/null
@@ -1,3 +0,0 @@
-Fixed a minor bug in ``test_isoparser`` related to ``bytes``/``str`` handling.
-Fixed by @fhuang5 (gh issue #776, gh pr #879)
-
diff --git a/changelog.d/881.bugfix.rst b/changelog.d/881.bugfix.rst
deleted file mode 100644
index d171861..0000000
--- a/changelog.d/881.bugfix.rst
+++ /dev/null
@@ -1,3 +0,0 @@
-Parsing errors will now raise ``ParserError``, a subclass of ``ValueError``,
-which has a nicer string representation.
-Patch by @gfyoung (gh pr #881)
diff --git a/changelog.d/882.misc.rst b/changelog.d/882.misc.rst
deleted file mode 100644
index b2e920b..0000000
--- a/changelog.d/882.misc.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Reorganized ``parser`` methods by functionality.
-Patch by @jbrockmendel (gh pr #882)
diff --git a/changelog.d/890.misc.rst b/changelog.d/890.misc.rst
deleted file mode 100644
index 77975f8..0000000
--- a/changelog.d/890.misc.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Removed duplicate tests in test_parser and renamed one test class.
-Patch by @jbrockmendel (gh pr #890)
diff --git a/changelog.d/891.bugfix.rst b/changelog.d/891.bugfix.rst
deleted file mode 100644
index a5ed17a..0000000
--- a/changelog.d/891.bugfix.rst
+++ /dev/null
@@ -1,4 +0,0 @@
-``parser.parse`` will now raise ``TypeError`` when ``tzinfos`` is passed a type
-that cannot be interpreted as a time zone. Prior to this change, it would raise
-an ``UnboundLocalError`` instead.
-Patch by @jbrockmendel (gh pr #891)
diff --git a/changelog.d/891.misc.rst b/changelog.d/891.misc.rst
deleted file mode 100644
index 2e7a44d..0000000
--- a/changelog.d/891.misc.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Added tests for tzinfos input types.
-Patch by @jbrockmendel (gh pr #891)
diff --git a/changelog.d/892.misc.rst b/changelog.d/892.misc.rst
deleted file mode 100644
index 1607555..0000000
--- a/changelog.d/892.misc.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Added test cases for parser.
-Patch by @jbrockmendel (gh pr #892)
diff --git a/changelog.d/893.misc.rst b/changelog.d/893.misc.rst
deleted file mode 100644
index fed687e..0000000
--- a/changelog.d/893.misc.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Fix tests if TZ not change allowed.
-Patch by @shadchin (gh pr #893)
diff --git a/changelog.d/894.misc.rst b/changelog.d/894.misc.rst
deleted file mode 100644
index 9faadab..0000000
--- a/changelog.d/894.misc.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Parametrized parser test cases.
-Patch by @jbrockmendel (gh pr #894)
diff --git a/changelog.d/910.bugfix.rst b/changelog.d/910.bugfix.rst
deleted file mode 100644
index d3601f4..0000000
--- a/changelog.d/910.bugfix.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Updated many modules to use ``tz.UTC`` in favor of ``tz.tzutc()`` internally,
-to avoid an unnecessary function call.
diff --git a/changelog.d/915.misc.rst b/changelog.d/915.misc.rst
deleted file mode 100644
index 0a1fa57..0000000
--- a/changelog.d/915.misc.rst
+++ /dev/null
@@ -1 +0,0 @@
-Explicitly listed all markers used in the pytest configuration.
diff --git a/changelog.d/916.misc.rst b/changelog.d/916.misc.rst
deleted file mode 100644
index eeb48f4..0000000
--- a/changelog.d/916.misc.rst
+++ /dev/null
@@ -1,3 +0,0 @@
-The Azure pipelines script now allows the ``tox -e coverage,codecov`` invocation
-to fail without error, since codecov integration with Azure pipelines is not
-yet set up.
diff --git a/changelog.d/928.bugfix.rst b/changelog.d/928.bugfix.rst
deleted file mode 100644
index 01d19a4..0000000
--- a/changelog.d/928.bugfix.rst
+++ /dev/null
@@ -1 +0,0 @@
-Fixed issue where ``test_tzlocal_offset_equal`` would fail in certain environments (such as FreeBSD) due to an invalid assumption about what time zone names are provided. Reported and fixed by Kubilay Kocak (gh issue #918, pr #928).
diff --git a/changelog.d/934.misc.rst b/changelog.d/934.misc.rst
deleted file mode 100644
index a3d35e0..0000000
--- a/changelog.d/934.misc.rst
+++ /dev/null
@@ -1 +0,0 @@
-Pinned all test dependencies on Python 3.3.
diff --git a/changelog.d/935.misc.rst b/changelog.d/935.misc.rst
deleted file mode 100644
index 672f60d..0000000
--- a/changelog.d/935.misc.rst
+++ /dev/null
@@ -1 +0,0 @@
-Raise a more helpful TypeError message when passing a bytes zonename to gettz in Python 3. Reported by @labrys (gh issue #927). Fixed by @labrys (gh pr #935)
diff --git a/changelog.d/950.bugfix.rst b/changelog.d/950.bugfix.rst
deleted file mode 100644
index b3054dc..0000000
--- a/changelog.d/950.bugfix.rst
+++ /dev/null
@@ -1 +0,0 @@
-Changed compatibility logic to support a potential Python 4.0 release. Patch by Hugo van Kemenade (gh pr #950)
diff --git a/changelog.d/952.misc.rst b/changelog.d/952.misc.rst
deleted file mode 100644
index baa2671..0000000
--- a/changelog.d/952.misc.rst
+++ /dev/null
@@ -1 +0,0 @@
-Fixed many misspellings, typos and styling errors in the comments and documentation. Patch by Hugo van Kemenade (gh pr #952)
diff --git a/changelog.d/961.data.rst b/changelog.d/961.data.rst
deleted file mode 100644
index b963a38..0000000
--- a/changelog.d/961.data.rst
+++ /dev/null
@@ -1 +0,0 @@
-Updated tzdata version to 2019c.
diff --git a/changelog.d/962.misc.rst b/changelog.d/962.misc.rst
deleted file mode 100644
index 6721629..0000000
--- a/changelog.d/962.misc.rst
+++ /dev/null
@@ -1 +0,0 @@
-Pin colorama in the Python 3.3 dependencies.
diff --git a/changelog.d/963.bugfix.rst b/changelog.d/963.bugfix.rst
deleted file mode 100644
index 2b1aabc..0000000
--- a/changelog.d/963.bugfix.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Fixed issue where ``dateutil.tz`` was using a backport of ``contextlib.nullcontext``
-even in Python 3.7 due to a malformed import statement.
diff --git a/changelog.d/966.misc.rst b/changelog.d/966.misc.rst
deleted file mode 100644
index a614255..0000000
--- a/changelog.d/966.misc.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Fix typo in setup.cfg causing PendingDeprecationWarning to not be explicitly
-specified as an error in the warnings filter.
diff --git a/changelog.d/969.misc.rst b/changelog.d/969.misc.rst
deleted file mode 100644
index 74149dd..0000000
--- a/changelog.d/969.misc.rst
+++ /dev/null
@@ -1 +0,0 @@
-Switched from using assertWarns to using pytest.warns in the test suite. (gh pr #969)
diff --git a/changelog.d/970.misc.rst b/changelog.d/970.misc.rst
deleted file mode 100644
index 2c17627..0000000
--- a/changelog.d/970.misc.rst
+++ /dev/null
@@ -1 +0,0 @@
-Added Python 3.8 to the trove classifiers and Travis CI builds. (gh pr #970)
diff --git a/changelog.d/971.misc.rst b/changelog.d/971.misc.rst
deleted file mode 100644
index 6fc8c30..0000000
--- a/changelog.d/971.misc.rst
+++ /dev/null
@@ -1 +0,0 @@
-Updated the release procedure and added tox environments to help with releasing. (gh pr #971)
diff --git a/changelog.d/973.bugfix.rst b/changelog.d/973.bugfix.rst
deleted file mode 100644
index 6af867c..0000000
--- a/changelog.d/973.bugfix.rst
+++ /dev/null
@@ -1 +0,0 @@
-Fixed a race condition in the ``tzoffset`` and ``tzstr`` "strong" caches on Python 2.7. Reported by @kainjow (gh issue #901).