summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTarek Ziade <tarek@ziade.org>2010-09-19 11:06:16 +0200
committerTarek Ziade <tarek@ziade.org>2010-09-19 11:06:16 +0200
commita9ba0fd0c9f4310a1cb5da5edc2226fd3e9d7ff4 (patch)
tree527dd176ab44e45e59baea2d6c6f707d77512b5b
parenta70165c20ce20318b78af0371b867aafe552235c (diff)
downloaddisutils2-a9ba0fd0c9f4310a1cb5da5edc2226fd3e9d7ff4.tar.gz
cleaned up setup.py and added a Makefile for the release1.0a2
-rw-r--r--Makefile17
-rw-r--r--setup.cfg3
-rw-r--r--setup.py2
3 files changed, 21 insertions, 1 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..9a67ffd
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,17 @@
+EZ = bin/easy_install
+VIRTUALENV = virtualenv
+PYTHON = bin/python
+HG = hg
+
+.PHONY: release build
+
+build:
+ $(VIRTUALENV) --no-site-packages --distribute .
+ $(PYTHON) setup.py build
+
+release:
+ hg tag `python setup.py --version`
+ hg ci -m "Release tagged"
+ cd docs; make html
+ $(PYTHON) setup.py upload_docs
+ $(PYTHON) setup.py register sdist upload
diff --git a/setup.cfg b/setup.cfg
index 169aaf6..bd3313c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,3 +1,6 @@
[build_ext]
# needed so that tests work without mucking with sys.path
inplace = 1
+
+[upload_docs]
+upload-dir = docs/build/html
diff --git a/setup.py b/setup.py
index 4a1794d..fb6b59a 100644
--- a/setup.py
+++ b/setup.py
@@ -219,7 +219,7 @@ setup(name="Distutils2",
description=README,
classifier=_CLASSIFIERS.split('\n'),
packages=find_packages(),
- cmdclass={'sdist': sdist_hg, 'install': install_hg},
+ cmdclass={'sdist_hg': sdist_hg, 'install_hg': install_hg},
package_data={'distutils2._backport': ['sysconfig.cfg']},
project_url=[('Mailing list',
'http://mail.python.org/mailman/listinfo/distutils-sig/'),