summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrubert <grubert@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2021-11-23 17:44:14 +0000
committergrubert <grubert@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2021-11-23 17:44:14 +0000
commite97ed1e6f72ce3bad587438a3dd7732a2adb94de (patch)
treee2c3f41433290612d2bfb07f693961b23ac5ec00
parent0284e5647b239fa46c47305289348c9c375f4bb9 (diff)
downloaddocutils-0.18.1@8900.tar.gz
Release 0.18.1docutils-0.18.1@8900
git-svn-id: https://svn.code.sf.net/p/docutils/code/trunk/docutils@8900 929543f6-e4f2-0310-98a6-ba3bd3dd1d04
-rw-r--r--HISTORY.txt4
-rw-r--r--README.txt6
-rw-r--r--RELEASE-NOTES.txt4
-rw-r--r--docutils/__init__.py8
-rwxr-xr-xsetup.py2
-rw-r--r--test/functional/expected/compact_lists.html2
-rw-r--r--test/functional/expected/dangerous.html2
-rw-r--r--test/functional/expected/embed_images_html5.html2
-rw-r--r--test/functional/expected/field_name_limit.html2
-rw-r--r--test/functional/expected/footnotes_html5.html2
-rw-r--r--test/functional/expected/math_output_html.html2
-rw-r--r--test/functional/expected/math_output_latex.html2
-rw-r--r--test/functional/expected/math_output_mathjax.html2
-rw-r--r--test/functional/expected/math_output_mathml.html2
-rw-r--r--test/functional/expected/misc_rst_html4css1.html2
-rw-r--r--test/functional/expected/misc_rst_html5.html2
-rw-r--r--test/functional/expected/pep_html.html2
-rw-r--r--test/functional/expected/standalone_rst_docutils_xml.xml2
-rw-r--r--test/functional/expected/standalone_rst_html4css1.html2
-rw-r--r--test/functional/expected/standalone_rst_html5.html2
-rw-r--r--test/functional/expected/standalone_rst_s5_html_1.html2
-rw-r--r--test/functional/expected/standalone_rst_s5_html_2.html2
22 files changed, 29 insertions, 29 deletions
diff --git a/HISTORY.txt b/HISTORY.txt
index 20bd119c0..6b69d1be8 100644
--- a/HISTORY.txt
+++ b/HISTORY.txt
@@ -11,8 +11,8 @@
.. contents::
-Release 0.18.1 (in preparation)
-===============================
+Release 0.18.1
+==============
* docutils/nodes.py
diff --git a/README.txt b/README.txt
index ce258a27b..401dff83d 100644
--- a/README.txt
+++ b/README.txt
@@ -1,6 +1,6 @@
-===============================
- README: Docutils 0.18.1b1.dev
-===============================
+=========================
+ README: Docutils 0.18.1
+=========================
:Author: David Goodger
:Contact: goodger@python.org
diff --git a/RELEASE-NOTES.txt b/RELEASE-NOTES.txt
index 1d5b4cba0..1d341d0f0 100644
--- a/RELEASE-NOTES.txt
+++ b/RELEASE-NOTES.txt
@@ -83,8 +83,8 @@ Drop support for `old-format configuration files`_.
.. _use_latex_citations: docs/user/config.html#use-latex-citations
-Release 0.18.1b0
-================
+Release 0.18.1
+==============
.. Note::
diff --git a/docutils/__init__.py b/docutils/__init__.py
index d3a0eccee..a826e98f3 100644
--- a/docutils/__init__.py
+++ b/docutils/__init__.py
@@ -56,7 +56,7 @@ from collections import namedtuple
__docformat__ = 'reStructuredText'
-__version__ = '0.18.1b1.dev'
+__version__ = '0.18.1'
"""Docutils version identifier (complies with PEP 440)::
major.minor[.micro][releaselevel[serial]][.dev]
@@ -113,10 +113,10 @@ __version_info__ = VersionInfo(
major=0,
minor=18,
micro=1,
- releaselevel='beta', # one of 'alpha', 'beta', 'candidate', 'final'
+ releaselevel='final', # one of 'alpha', 'beta', 'candidate', 'final'
# pre-release serial number (0 for final releases and active development):
- serial=1,
- release=False # True for official releases and pre-releases
+ serial=0,
+ release=True # True for official releases and pre-releases
)
"""Comprehensive version information tuple. See 'Version Numbering' in
docs/dev/policies.txt."""
diff --git a/setup.py b/setup.py
index 3c370fa05..e2daf4f20 100755
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,7 @@ into useful formats, such as HTML, XML, and LaTeX. For
input Docutils supports reStructuredText, an easy-to-read,
what-you-see-is-what-you-get plaintext markup syntax.""", # wrap at col 60
'url': 'http://docutils.sourceforge.net/',
- 'version': '0.18.1b1.dev',
+ 'version': '0.18.1',
'author': 'David Goodger',
'author_email': 'goodger@python.org',
'maintainer': 'docutils-develop list',
diff --git a/test/functional/expected/compact_lists.html b/test/functional/expected/compact_lists.html
index 7ac702cd5..963abe734 100644
--- a/test/functional/expected/compact_lists.html
+++ b/test/functional/expected/compact_lists.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>compact_lists.txt</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/test/functional/expected/dangerous.html b/test/functional/expected/dangerous.html
index c09739869..08634e1ab 100644
--- a/test/functional/expected/dangerous.html
+++ b/test/functional/expected/dangerous.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>dangerous.txt</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/test/functional/expected/embed_images_html5.html b/test/functional/expected/embed_images_html5.html
index 1f0bf2ee8..ddd9071bb 100644
--- a/test/functional/expected/embed_images_html5.html
+++ b/test/functional/expected/embed_images_html5.html
@@ -3,7 +3,7 @@
<head>
<meta charset="utf-8"/>
<meta name="viewport" content="width=device-width, initial-scale=1" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>Embedded Images</title>
<link rel="stylesheet" href="../input/data/minimal.css" type="text/css" />
<link rel="stylesheet" href="../input/data/plain.css" type="text/css" />
diff --git a/test/functional/expected/field_name_limit.html b/test/functional/expected/field_name_limit.html
index 7036034ca..be081e818 100644
--- a/test/functional/expected/field_name_limit.html
+++ b/test/functional/expected/field_name_limit.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>field_list.txt</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/test/functional/expected/footnotes_html5.html b/test/functional/expected/footnotes_html5.html
index 14298790b..da9c3206a 100644
--- a/test/functional/expected/footnotes_html5.html
+++ b/test/functional/expected/footnotes_html5.html
@@ -3,7 +3,7 @@
<head>
<meta charset="utf-8"/>
<meta name="viewport" content="width=device-width, initial-scale=1" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>Test footnote and citation rendering</title>
<link rel="stylesheet" href="../input/data/minimal.css" type="text/css" />
<link rel="stylesheet" href="../input/data/responsive.css" type="text/css" />
diff --git a/test/functional/expected/math_output_html.html b/test/functional/expected/math_output_html.html
index 35749cdfa..38e8dfcd1 100644
--- a/test/functional/expected/math_output_html.html
+++ b/test/functional/expected/math_output_html.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>Mathematics</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
<link rel="stylesheet" href="../input/data/math.css" type="text/css" />
diff --git a/test/functional/expected/math_output_latex.html b/test/functional/expected/math_output_latex.html
index 65aa1e362..f7f66f64e 100644
--- a/test/functional/expected/math_output_latex.html
+++ b/test/functional/expected/math_output_latex.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>Mathematics</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/test/functional/expected/math_output_mathjax.html b/test/functional/expected/math_output_mathjax.html
index 9a321d0bd..7ada17800 100644
--- a/test/functional/expected/math_output_mathjax.html
+++ b/test/functional/expected/math_output_mathjax.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>Mathematics</title>
<script type="text/javascript" src="/usr/share/javascript/mathjax/MathJax.js?config=TeX-AMS_CHTML"></script>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
diff --git a/test/functional/expected/math_output_mathml.html b/test/functional/expected/math_output_mathml.html
index ed6821040..cf4c0d3ad 100644
--- a/test/functional/expected/math_output_mathml.html
+++ b/test/functional/expected/math_output_mathml.html
@@ -3,7 +3,7 @@
<head>
<meta charset="utf-8"/>
<meta name="viewport" content="width=device-width, initial-scale=1" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>Mathematics</title>
<link rel="stylesheet" href="../input/data/minimal.css" type="text/css" />
<link rel="stylesheet" href="../input/data/plain.css" type="text/css" />
diff --git a/test/functional/expected/misc_rst_html4css1.html b/test/functional/expected/misc_rst_html4css1.html
index 5bccae375..93b2b9938 100644
--- a/test/functional/expected/misc_rst_html4css1.html
+++ b/test/functional/expected/misc_rst_html4css1.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>Additional tests with html4css1</title>
<link rel="stylesheet" href="foo&amp;bar.css" type="text/css" />
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
diff --git a/test/functional/expected/misc_rst_html5.html b/test/functional/expected/misc_rst_html5.html
index c0a44414c..e7f9c35c1 100644
--- a/test/functional/expected/misc_rst_html5.html
+++ b/test/functional/expected/misc_rst_html5.html
@@ -3,7 +3,7 @@
<head>
<meta charset="utf-8"/>
<meta name="viewport" content="width=device-width, initial-scale=1" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>Additional tests with HTML 5</title>
<link rel="stylesheet" href="../input/data/minimal.css" type="text/css" />
<link rel="stylesheet" href="../input/data/responsive.css" type="text/css" />
diff --git a/test/functional/expected/pep_html.html b/test/functional/expected/pep_html.html
index eb7e16326..088896aca 100644
--- a/test/functional/expected/pep_html.html
+++ b/test/functional/expected/pep_html.html
@@ -8,7 +8,7 @@ to templates. DO NOT USE THIS HTML FILE AS YOUR TEMPLATE!
-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
- <meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+ <meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>PEP 100 -- Test PEP</title>
<link rel="stylesheet" href="../input/data/html4css1.css" type="text/css" />
</head>
diff --git a/test/functional/expected/standalone_rst_docutils_xml.xml b/test/functional/expected/standalone_rst_docutils_xml.xml
index a795c6e17..7cfe9c3a3 100644
--- a/test/functional/expected/standalone_rst_docutils_xml.xml
+++ b/test/functional/expected/standalone_rst_docutils_xml.xml
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE document PUBLIC "+//IDN docutils.sourceforge.net//DTD Docutils Generic//EN//XML" "http://docutils.sourceforge.net/docs/ref/docutils.dtd">
-<!-- Generated by Docutils 0.18.1b1.dev -->
+<!-- Generated by Docutils 0.18.1 -->
<document ids="restructuredtext-test-document doctitle" names="restructuredtext\ test\ document doctitle" source="functional/input/standalone_rst_docutils_xml.txt" title="reStructuredText Test Document">
<title>reStructuredText Test Document</title>
<subtitle ids="examples-of-syntax-constructs subtitle" names="examples\ of\ syntax\ constructs subtitle">Examples of Syntax Constructs</subtitle>
diff --git a/test/functional/expected/standalone_rst_html4css1.html b/test/functional/expected/standalone_rst_html4css1.html
index 3db6bbdfe..897f42ef7 100644
--- a/test/functional/expected/standalone_rst_html4css1.html
+++ b/test/functional/expected/standalone_rst_html4css1.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>reStructuredText Test Document</title>
<meta content="reStructuredText, test, parser" name="keywords" />
<meta content="A test document, containing at least one example of each reStructuredText construct." lang="en" name="description" />
diff --git a/test/functional/expected/standalone_rst_html5.html b/test/functional/expected/standalone_rst_html5.html
index b0a0ebc7c..86f64b2c1 100644
--- a/test/functional/expected/standalone_rst_html5.html
+++ b/test/functional/expected/standalone_rst_html5.html
@@ -3,7 +3,7 @@
<head>
<meta charset="utf-8"/>
<meta name="viewport" content="width=device-width, initial-scale=1" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>reStructuredText Test Document</title>
<meta content="reStructuredText, test, parser" name="keywords" />
<meta content="A test document, containing at least one example of each reStructuredText construct." lang="en" name="description" xml:lang="en" />
diff --git a/test/functional/expected/standalone_rst_s5_html_1.html b/test/functional/expected/standalone_rst_s5_html_1.html
index fb663354a..4ee5e7048 100644
--- a/test/functional/expected/standalone_rst_s5_html_1.html
+++ b/test/functional/expected/standalone_rst_s5_html_1.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<meta name="version" content="S5 1.1" />
<title>Slide Shows</title>
<meta name="author" content="David Goodger" />
diff --git a/test/functional/expected/standalone_rst_s5_html_2.html b/test/functional/expected/standalone_rst_s5_html_2.html
index cdff373e0..dc83dff6f 100644
--- a/test/functional/expected/standalone_rst_s5_html_2.html
+++ b/test/functional/expected/standalone_rst_s5_html_2.html
@@ -3,7 +3,7 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.18.1b1.dev: http://docutils.sourceforge.net/" />
+<meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<meta name="version" content="S5 1.1" />
<title>Slide Shows</title>
<meta name="author" content="David Goodger" />