summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormilde <milde@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2018-11-26 21:50:13 +0000
committermilde <milde@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2018-11-26 21:50:13 +0000
commit34df3821554a2f406560615ea3de78bdf8c17486 (patch)
treeb026a2b13338c0535bfbe8b4849733d6ae1f3f75
parent4d8f87502ece5bd0a385f3261cdc9e3e31a0f30c (diff)
downloaddocutils-34df3821554a2f406560615ea3de78bdf8c17486.tar.gz
Specify Python version requirements in setup.py.
Also drop a version check for no-longer supported versions 3.1 and 3.2. Patch [ 145 ] by Hugo. Thanks. git-svn-id: http://svn.code.sf.net/p/docutils/code/trunk@8241 929543f6-e4f2-0310-98a6-ba3bd3dd1d04
-rwxr-xr-xdocutils/setup.py5
-rwxr-xr-xdocutils/test/test_parsers/test_rst/test_directives/test_tables.py3
2 files changed, 6 insertions, 2 deletions
diff --git a/docutils/setup.py b/docutils/setup.py
index 0642d3499..82f006e53 100755
--- a/docutils/setup.py
+++ b/docutils/setup.py
@@ -122,6 +122,7 @@ what-you-see-is-what-you-get plaintext markup syntax.""", # wrap at col 60
'maintainer_email': 'docutils-develop@lists.sourceforge.net',
'license': 'public domain, Python, 2-Clause BSD, GPL 3 (see COPYING.txt)',
'platforms': 'OS-independent',
+ 'python_requires': '>=2.6, !=3.0.*, !=3.1.*, !=3.2.*',
'package_dir': {'docutils': 'docutils',
'docutils.tools': 'tools'},
'packages': ['docutils',
@@ -194,9 +195,13 @@ classifiers = [
'License :: OSI Approved :: BSD License',
'License :: OSI Approved :: GNU General Public License (GPL)',
'Operating System :: OS Independent',
+ 'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
'Topic :: Documentation',
'Topic :: Software Development :: Documentation',
'Topic :: Text Processing',
diff --git a/docutils/test/test_parsers/test_rst/test_directives/test_tables.py b/docutils/test/test_parsers/test_rst/test_directives/test_tables.py
index 2b71144d0..0cce57809 100755
--- a/docutils/test/test_parsers/test_rst/test_directives/test_tables.py
+++ b/docutils/test/test_parsers/test_rst/test_directives/test_tables.py
@@ -37,8 +37,7 @@ else:
# CPython has backported to 2.7.4, PyPy has not
# platform.python_implementation is new in 2.6
csv_eod_error_str = 'unexpected end of data'
-if ((3,) < sys.version_info < (3,2,4) or sys.version_info < (2,7,4)
- or platform.python_implementation() == 'PyPy'):
+if sys.version_info < (2,7,4) or platform.python_implementation() == 'PyPy':
csv_eod_error_str = 'newline inside string'
# pypy adds a line number
if sys.version_info > (2, 6) and platform.python_implementation() == 'PyPy':