summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2021-12-16 13:43:33 -0600
committerJason Madden <jamadden@gmail.com>2021-12-16 13:43:33 -0600
commit2d6e3315d0a97939e8831cba53bb53445841e77e (patch)
tree74dc1c507c05999ed1ace5810e7fa2e88c052442
parentbe41e1a24925326b72a02ef5cb6d1ed9643eb062 (diff)
downloadgreenlet-2d6e3315d0a97939e8831cba53bb53445841e77e.tar.gz
Try adding CodeQL analysis.
-rw-r--r--.github/workflows/tests.yml33
1 files changed, 33 insertions, 0 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 540a969..7316ffe 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -119,6 +119,39 @@ jobs:
python -c 'import greenlet._greenlet as G; assert not G.GREENLET_USE_STANDARD_THREADING'
python -m unittest discover -v greenlet.tests
+ CodeQL:
+ runs-on: ubuntu-latest
+ permissions:
+ # required for all workflows
+ security-events: write
+ steps:
+ - uses: actions/checkout@v2
+ - name: Set up Python
+ uses: actions/setup-python@v2
+ with:
+ python-version: "3.10"
+ - name: Pip cache
+ uses: actions/cache@v2
+ with:
+ path: ~/.cache/pip
+ key: ${{ runner.os }}-pip-ql-${{ hashFiles('setup.*') }}
+ restore-keys: |
+ ${{ runner.os }}-pip-ql-
+ # Initializes the CodeQL tools for scanning.
+ - name: Initialize CodeQL
+ uses: github/codeql-action/init@v1
+ with:
+ languages: python, cpp
+ - name: Install dependencies
+ run: |
+ python -m pip install -U pip setuptools wheel
+ - name: Install greenlet
+ run: |
+ python setup.py bdist_wheel
+ python -m pip install -U -v -e ".[test,docs]"
+ - name: Perform CodeQL Analysis
+ uses: github/codeql-action/analyze@v1
+
manylinux:
runs-on: ubuntu-latest