summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorstaticdev <staticdev-support@protonmail.com>2022-01-05 18:05:49 +0100
committerstaticdev <staticdev-support@protonmail.com>2022-01-05 18:05:49 +0100
commit0011fcf9daeff3c2e4d6e564a753b463bf43ba22 (patch)
treebce65b563f936e4e364e6558954ee243a8304a18
parent98673ff4bc158fdc79f587775b6a15abd9fdc248 (diff)
downloadisort-0011fcf9daeff3c2e4d6e564a753b463bf43ba22.tar.gz
Updates hard requirements on pyproject.tomls
-rw-r--r--example_isort_formatting_plugin/pyproject.toml6
-rw-r--r--example_isort_sorting_plugin/pyproject.toml6
-rw-r--r--example_shared_isort_profile/pyproject.toml6
-rw-r--r--pyproject.toml8
4 files changed, 13 insertions, 13 deletions
diff --git a/example_isort_formatting_plugin/pyproject.toml b/example_isort_formatting_plugin/pyproject.toml
index b42344fe..25ce0174 100644
--- a/example_isort_formatting_plugin/pyproject.toml
+++ b/example_isort_formatting_plugin/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "example_isort_formatting_plugin"
-version = "0.0.4"
+version = "0.0.5"
description = "An example plugin that modifies isort formatting using black."
authors = ["Timothy Crosley <timothy.crosley@gmail.com>"]
license = "MIT"
@@ -9,12 +9,12 @@ license = "MIT"
example = "example_isort_formatting_plugin:black_format_import_section"
[tool.poetry.dependencies]
-python = ">=3.6.2,<4.0"
+python = ">=3.6.2"
isort = "^5.1.4"
black = ">20.08b1"
[tool.poetry.dev-dependencies]
[build-system]
-requires = ["poetry>=0.12"]
+requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.masonry.api"
diff --git a/example_isort_sorting_plugin/pyproject.toml b/example_isort_sorting_plugin/pyproject.toml
index fce37594..cafcfcaa 100644
--- a/example_isort_sorting_plugin/pyproject.toml
+++ b/example_isort_sorting_plugin/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "example_isort_sorting_plugin"
-version = "0.0.3"
+version = "0.0.4"
description = "An example plugin that modifies isorts sorting order to provide an even more natural sort by utilizing natsort."
authors = ["Timothy Crosley <timothy.crosley@gmail.com>"]
license = "MIT"
@@ -9,11 +9,11 @@ license = "MIT"
natural_plus = "example_isort_sorting_plugin:natural_plus"
[tool.poetry.dependencies]
-python = "^3.6"
+python = ">=3.6"
natsort = ">=7.1.1"
[tool.poetry.dev-dependencies]
[build-system]
-requires = ["poetry>=0.12"]
+requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.masonry.api"
diff --git a/example_shared_isort_profile/pyproject.toml b/example_shared_isort_profile/pyproject.toml
index 7a290ddc..48fa5085 100644
--- a/example_shared_isort_profile/pyproject.toml
+++ b/example_shared_isort_profile/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "example_shared_isort_profile"
-version = "0.0.1"
+version = "0.0.2"
description = "An example shared isort profile"
authors = ["Timothy Crosley <timothy.crosley@gmail.com>"]
license = "MIT"
@@ -9,10 +9,10 @@ license = "MIT"
example = "example_shared_isort_profile:PROFILE"
[tool.poetry.dependencies]
-python = "^3.6"
+python = ">=3.6"
[tool.poetry.dev-dependencies]
[build-system]
-requires = ["poetry>=0.12"]
+requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.masonry.api"
diff --git a/pyproject.toml b/pyproject.toml
index adbb4984..9d366284 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -40,7 +40,7 @@ include = [
]
[tool.poetry.dependencies]
-python = ">=3.6.2,<4.0"
+python = ">=3.6.2"
pipreqs = {version = "*", optional = true}
requirementslib = {version = "*", optional = true}
pip-api = {version = "*", optional = true}
@@ -82,9 +82,9 @@ pip-shims = "^0.5.2"
smmap2 = "^3.0.1"
gitdb2 = "^4.0.2"
httpx = "^0.13.3"
-example_shared_isort_profile = "^0.0.1"
-example_isort_formatting_plugin = "^0.0.4"
-example_isort_sorting_plugin = "^0.0.3"
+example_shared_isort_profile = ">=0.0.2"
+example_isort_formatting_plugin = ">=0.0.5"
+example_isort_sorting_plugin = ">=0.0.4"
flake8 = "^3.8.4"
hypothesis = "^6.10.1"
libcst = "^0.3.18"