summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2019-10-12 01:23:18 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2019-10-12 01:23:18 -0700
commit635ecd045994f4f5df0ef1b1854de21f4c9860a0 (patch)
tree98b60d2fe797d28c56491fd17995c1020733f8c7
parent20ac404b3f821c8056c0bae43e13c26f970046df (diff)
downloadisort-635ecd045994f4f5df0ef1b1854de21f4c9860a0.tar.gz
Add pyproject.toml and remove setup.py
-rw-r--r--pyproject.toml74
-rwxr-xr-xsetup.py48
2 files changed, 74 insertions, 48 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 00000000..8ee8c7ec
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,74 @@
+[tool.poetry]
+name = "isort"
+version = "4.3.21"
+description = "A Python utility / library to sort Python imports."
+authors = ["Timothy Crosley <timothy.crosley@gmail.com>"]
+license = "MIT"
+readme = "README.rst"
+repository = "https://github.com/timothycrosley/isort"
+website = "http://timothycrosley.github.io/isort/"
+keywords = ["Refactor", "Lint", "Imports", "Sort", "Clean"]
+classifiers = [
+ "Development Status :: 6 - Mature",
+ "Intended Audience :: Developers",
+ "Natural Language :: English",
+ "Environment :: Console",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3 :: Only",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Topic :: Software Development :: Libraries",
+ "Topic :: Utilities",
+]
+
+[tool.poetry.dependencies]
+python = "^3.5"
+appdirs = {version = "^1.4.0", optional = true}
+pipreqs = {version = "*", optional = true}
+requirementslib = {version = "*", optional = true}
+toml = {version = "*", optional = true}
+pip-api = {version = "*", optional = true}
+
+[tool.poetry.extras]
+pipfile = ["pipreqs", "requirementslib"]
+pyproject = ["toml"]
+requirements = ["pipreqs", "pip-api"]
+xdg_home = ["appdirs"]
+
+[tool.poetry.dev-dependencies]
+vulture = "^1.0"
+bandit = "^1.6"
+safety = "^1.8"
+flake8-bugbear = "^19.8"
+black = {version = "^18.3-alpha.0", allows-prereleases = true, optional = true, python = "^3.6"}
+mypy = "^0.730.0"
+ipython = "^7.7"
+pytest = "^5.0"
+pytest-cov = "^2.7"
+pytest-mock = "^1.10"
+pep8-naming = "^0.8.2"
+portray = { version = "^1.3.0", optional = true, python = "^3.6" }
+appdirs = "^1.4"
+pipfile = "^0.0.2"
+pyproject = "^1.3"
+requirementslib = "^1.5"
+pipreqs = "^0.4.9"
+tomlkit = "^0.5.8"
+
+[tool.poetry.scripts]
+isort = "isort.main:main"
+
+[tool.poetry.plugins."distutils.commands"]
+isort = "isort.main:ISortCommand"
+
+[tool.poetry.plugins."pylama.linter"]
+isort = "isort = isort.pylama_isort:Linter"
+
+[build-system]
+requires = ["poetry>=0.12"]
+build-backend = "poetry.masonry.api"
diff --git a/setup.py b/setup.py
deleted file mode 100755
index 2ba4164a..00000000
--- a/setup.py
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/usr/bin/env python3
-
-from setuptools import find_packages, setup
-
-with open("README.rst") as f:
- readme = f.read()
-
-setup(
- name="isort",
- version="4.3.21",
- description="A Python utility / library to sort Python imports.",
- long_description=readme,
- author="Timothy Crosley",
- author_email="timothy.crosley@gmail.com",
- url="https://github.com/timothycrosley/isort",
- license="MIT",
- entry_points={
- "console_scripts": ["isort = isort.main:main"],
- "distutils.commands": ["isort = isort.main:ISortCommand"],
- "pylama.linter": ["isort = isort.pylama_isort:Linter"],
- },
- packages=find_packages(),
- extras_require={
- "pipfile": ["pipreqs", "requirementslib"],
- "pyproject": ["toml"],
- "requirements": ["pipreqs", "pip-api"],
- "xdg_home": ["appdirs>=1.4.0"],
- },
- python_requires=">=3.5",
- keywords="Refactor, Python, Python3, Refactoring, Imports, Sort, Clean",
- classifiers=[
- "Development Status :: 6 - Mature",
- "Intended Audience :: Developers",
- "Natural Language :: English",
- "Environment :: Console",
- "License :: OSI Approved :: MIT License",
- "Programming Language :: Python",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6",
- "Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3 :: Only",
- "Programming Language :: Python :: Implementation :: CPython",
- "Programming Language :: Python :: Implementation :: PyPy",
- "Topic :: Software Development :: Libraries",
- "Topic :: Utilities",
- ],
-)