summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2009-10-07 10:40:52 +0200
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2009-10-07 10:40:52 +0200
commit95078ba52248efae2c126f3c411e86e45103b878 (patch)
tree7b42eeeadd02184a7da9c776b6d2ba36ffe280c9
parent0e1f1a83ebd0a03999a39accf860591cfb1e743c (diff)
parent6d3568224063eaf87fe77aa9fd8c7e54d1851c1b (diff)
downloadlogilab-common-95078ba52248efae2c126f3c411e86e45103b878.tar.gz
merge
-rw-r--r--__pkginfo__.py2
-rw-r--r--configuration.py2
-rw-r--r--debian/changelog6
-rw-r--r--tasksqueue.py6
-rw-r--r--test/unittest_configuration.py3
5 files changed, 15 insertions, 4 deletions
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 148b3d8..6c8e06a 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -8,7 +8,7 @@ __docformat__ = "restructuredtext en"
distname = 'logilab-common'
modname = 'common'
-numversion = (0, 45, 0)
+numversion = (0, 45, 1)
version = '.'.join([str(num) for num in numversion])
license = 'GPL'
diff --git a/configuration.py b/configuration.py
index f24a99d..539fa9c 100644
--- a/configuration.py
+++ b/configuration.py
@@ -446,8 +446,6 @@ class OptionsManagerMixIn(object):
else:
opt_dict['action'] = 'callback'
opt_dict['callback'] = self.cb_set_provider_option
- if 'choices' in opt_dict:
- opt_dict['help'] += ': %s' % '|'.join(opt_dict['choices'])
# default is handled here and *must not* be given to optik if you
# want the whole machinery to work
if 'default' in opt_dict:
diff --git a/debian/changelog b/debian/changelog
index 8460636..e48a1e0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+logilab-common (0.45.1-1) unstable; urgency=low
+
+ * new upstream release
+
+ -- Sylvain Thénault <sylvain.thenault@logilab.fr> Wed, 07 Oct 2009 10:32:20 +0200
+
logilab-common (0.45.0-1) unstable; urgency=low
* new upstream release
diff --git a/tasksqueue.py b/tasksqueue.py
index 008a625..0165340 100644
--- a/tasksqueue.py
+++ b/tasksqueue.py
@@ -13,6 +13,12 @@ LOW = 0
MEDIUM = 10
HIGH = 100
+REVERSE_PRIORITY = {
+ 0: 'LOW',
+ 10: 'MEDIUM',
+ 100: 'HIGH'
+ }
+
class PrioritizedTasksQueue(Queue):
diff --git a/test/unittest_configuration.py b/test/unittest_configuration.py
index c68f0d3..828309f 100644
--- a/test/unittest_configuration.py
+++ b/test/unittest_configuration.py
@@ -4,7 +4,8 @@ from cStringIO import StringIO
from sys import version_info
from logilab.common.testlib import TestCase, unittest_main
-from logilab.common.configuration import Configuration, OptionValueError, \
+from logilab.common.optik_ext import OptionValueError
+from logilab.common.configuration import Configuration, \
OptionsManagerMixIn, OptionsProviderMixIn, Method, read_old_config
options = [('dothis', {'type':'yn', 'action': 'store', 'default': True, 'metavar': '<y or n>'}),