summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2010-02-26 07:17:55 +0100
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2010-02-26 07:17:55 +0100
commitdadc952c8766a9d5bc919b54353e658508232461 (patch)
tree7e454d19c69ef608216fa775364e58d992d86883
parentd51b1802baab7c7c8384beaa36c2d5403ad5ae1d (diff)
parent7c8ffdff480d07d4915f3b75c223015ae199ab78 (diff)
downloadlogilab-common-dadc952c8766a9d5bc919b54353e658508232461.tar.gz
merge
-rw-r--r--ChangeLog22
-rw-r--r--__pkginfo__.py2
-rw-r--r--debian/changelog6
-rw-r--r--decorators.py2
-rw-r--r--deprecation.py2
5 files changed, 27 insertions, 7 deletions
diff --git a/ChangeLog b/ChangeLog
index 7da16e6..975947b 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,25 +1,37 @@
ChangeLog for logilab.common
============================
- --
+2010-02-26 -- 0.48.1
* adbh: added dbport optional argument to [backup|restore]_commands
-2010-02-17 -- 0.48.0
- * date: fixed mx date time compat for date_range (#20651)
- * testlib: generative test should not be interrupted by self.skip() (#20648)
+ * db: fix date processing for SQLServer 2005
-2010-02-10 -- 0.47.0
+ * testlib: improve XML assertion by using ElementTree parser and a new 'context' lines argument
+
+
+
+2010-02-17 -- 0.48.0
+ * date: fixed mx date time compat for date_range (#20651)
+
+ * testlib: generative test should not be interrupted by self.skip() (#20648)
+
+
+
+2010-02-10 -- 0.47.0
* adbh: changed backup / restore api (BREAKS COMPAT):
- backup_command is now backup_commands (eg return a list of commands)
- each command returned in backup_commands/restore_commands may now
be list that may be used as argument to subprocess.call, or a string
which will the requires a subshell
- new sql_rename_col method
+
* deprecation: deprecated now takes an optional 'stacklevel' argument, default to 2
+
* date: some functions to ease python's datetime module usage have been backported
from cubicweb
+
2009-12-23 -- 0.46.0
* db / adbh: added SQL Server support using Pyodbc
diff --git a/__pkginfo__.py b/__pkginfo__.py
index bebbf58..c5ba9d2 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -8,7 +8,7 @@ __docformat__ = "restructuredtext en"
distname = 'logilab-common'
modname = 'common'
-numversion = (0, 48, 0)
+numversion = (0, 48, 1)
version = '.'.join([str(num) for num in numversion])
copyright = '2000-2010 LOGILAB S.A. (Paris, FRANCE), all rights reserved.'
license = 'GPL'
diff --git a/debian/changelog b/debian/changelog
index 668f0e4..4965465 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+logilab-common (0.48.1-1) unstable; urgency=low
+
+ * new upstream release
+
+ -- Sylvain Thénault <sylvain.thenault@logilab.fr> Fri, 26 Feb 2010 07:12:06 +0100
+
logilab-common (0.48.0-1) unstable; urgency=low
* new upstream release
diff --git a/decorators.py b/decorators.py
index f5278cc..b656be6 100644
--- a/decorators.py
+++ b/decorators.py
@@ -1,6 +1,6 @@
"""A few useful function/method decorators.
-:copyright: 2006-2008 LOGILAB S.A. (Paris, FRANCE), all rights reserved.
+:copyright: 2006-2010 LOGILAB S.A. (Paris, FRANCE), all rights reserved.
:contact: http://www.logilab.fr/ -- mailto:contact@logilab.fr
:license: General Public License version 2 - http://www.gnu.org/licenses
"""
diff --git a/deprecation.py b/deprecation.py
index 24b588c..587a651 100644
--- a/deprecation.py
+++ b/deprecation.py
@@ -69,6 +69,8 @@ def deprecated(reason=None, stacklevel=2):
def wrapped(*args, **kwargs):
warn(message, DeprecationWarning, stacklevel=stacklevel)
return func(*args, **kwargs)
+ wrapped.__name__ = func.__name__
+ wrapped.__doc__ = func.__doc__
return wrapped
return deprecated_decorator