summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Jehannet <julien.jehannet@logilab.fr>2010-03-24 18:39:14 +0100
committerJulien Jehannet <julien.jehannet@logilab.fr>2010-03-24 18:39:14 +0100
commitd357ea88211fc3abdfdddcda1a97a625325cc804 (patch)
treeb09cd363db7c6fd6d54589c017500590e0a5448d
parent3bc9e538dbd479f051c1481134bd3fe18f59842e (diff)
downloadlogilab-common-d357ea88211fc3abdfdddcda1a97a625325cc804.tar.gz
[F] debian: manage --install-layout option for all distributions correctly
`/usr/share/python/python.mk` present from squeeze release proposed backport support
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules14
2 files changed, 11 insertions, 5 deletions
diff --git a/debian/control b/debian/control
index 796a080..b7d1257 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,6 @@ Uploaders: David Douard <david.douard@logilab.fr>,
Nicolas Chauvat <nicolas.chauvat@logilab.fr>
Build-Depends: debhelper (>= 5.0.38), python (>= 2.4.6-2)
Build-Depends-Indep: python-support, python-epydoc, graphviz
-XS-Python-Version: all
Standards-Version: 3.8.2
Homepage: http://www.logilab.org/project/logilab-common
Vcs-Svn: svn://svn.debian.org/svn/python-modules/packages/logilab-common/trunk/
@@ -22,7 +21,6 @@ Provides: ${python:Provides}
Depends: ${python:Depends}, ${misc:Depends}
Recommends: python-egenix-mxdatetime
Conflicts: python-constraint ( <= 0.3.0-4), python-logilab-astng ( <= 0.16.0-1), pylint ( << 0.11.0-1), devtools ( <= 0.9.0-1), logilab-doctools ( <= 0.1.6-4), python-logilab-aspects ( <= 0.1.4-2), python2.3-logilab-common, python2.4-logilab-common, cubicweb-server ( << 3.6.0-1)
-XB-Python-Version: ${python:Versions}
Description: useful miscellaneous modules used by Logilab projects
logilab-common is a collection of low-level Python packages and modules,
designed to ease:
diff --git a/debian/rules b/debian/rules
index e1acbe2..e472b70 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,14 @@
#export DH_VERBOSE=1
PY_VERSION:=$(shell pyversions -vd)
+-include /usr/share/python/python.mk
+ifeq (,$(py_sitename))
+ py_sitename = site-packages
+ py_libdir = /usr/lib/python$(subst python,,$(1))/site-packages
+ py_sitename_sh = $(py_sitename)
+ py_libdir_sh = $(py_libdir)
+endif
+
build: build-stamp
build-stamp:
dh_testdir
@@ -24,13 +32,13 @@ ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
# we need this hack because we have to import "logilab.common.pytest"
# but since it's a namespace package, we need to "simulate" it
touch $(CURDIR)/build/lib/logilab/__init__.py
- -PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-$(PY_VERSION)/pytest
- rm -f $(CURDIR)/build/lib/logilab/__init__.py
+ PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-$(PY_VERSION)/pytest
endif
# build doc
$(MAKE) -C doc
+ rm -f $(CURDIR)/build/lib/logilab/__init__.py
touch build-stamp
clean:
@@ -56,7 +64,7 @@ install: build
NO_SETUPTOOLS=1 python setup.py -q install --prefix=/usr --no-compile \
--root=$(CURDIR)/debian/python-logilab-common/ \
- --install-layout=deb
+ ${py_setup_install_args}
# remove test directory
rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test