summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain <syt@logilab.fr>2008-04-22 11:29:11 +0200
committerSylvain <syt@logilab.fr>2008-04-22 11:29:11 +0200
commit46e6878d5afdea0156ddcc655e05a9ee39cd124b (patch)
tree4c5ab028d9ceb9cf57d44939f7052eff6e624f99
parent59c06236a3ab1813a505121669d6791a32a0027c (diff)
parentde477f4d5330295433be176025c32eaa856e5f20 (diff)
downloadlogilab-common-46e6878d5afdea0156ddcc655e05a9ee39cd124b.tar.gz
merge
-rw-r--r--MANIFEST.in1
-rw-r--r--__init__.py25
-rw-r--r--debian/changelog6
-rw-r--r--decorators.py2
4 files changed, 32 insertions, 2 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index a0c9338..5faa4dd 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -7,3 +7,4 @@ include bin/pytest.bat
recursive-include test/data *.py *.txt *.msg *.ini
recursive-include doc/html *
include doc/pytest.1
+include doc/makefile
diff --git a/__init__.py b/__init__.py
index e1ef63c..006f92b 100644
--- a/__init__.py
+++ b/__init__.py
@@ -93,7 +93,30 @@ class nullobject(object):
def __nonzero__(self):
return False
-# XXX move in a specific module
+# flatten -----
+# XXX move in a specific module and use yield instead
+# do not mix flatten and translate
+#
+# def iterable(obj):
+# try: iter(obj)
+# except: return False
+# return True
+#
+# def is_string_like(obj):
+# try: obj +''
+# except (TypeError, ValueError): return False
+# return True
+#
+#def is_scalar(obj):
+# return is_string_like(obj) or not iterable(obj)
+#
+#def flatten(seq):
+# for item in seq:
+# if is_scalar(item):
+# yield item
+# else:
+# for subitem in flatten(item):
+# yield subitem
def flatten(iterable, tr_func=None, results=None):
"""flatten a list of list with any level
diff --git a/debian/changelog b/debian/changelog
index 861f4e0..c37ea27 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+logilab-common (0.30.0-2) unstable; urgency=low
+
+ * upload to debian
+
+ -- Alexandre Fayolle <afayolle@debian.org> Mon, 21 Apr 2008 17:24:28 +0200
+
logilab-common (0.30.0-1) unstable; urgency=low
* new upstream release
diff --git a/decorators.py b/decorators.py
index fb9c818..72b88ff 100644
--- a/decorators.py
+++ b/decorators.py
@@ -92,7 +92,7 @@ def copy_cache(obj, funcname, cacheobj):
class wproperty(object):
"""simple descriptor expecting to take a modifier function as first argument
- and looking for a _<function name> to retreive the attribute
+ and looking for a _<function name> to retrieve the attribute
"""
def __init__(self, setfunc):
self.setfunc = setfunc