summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsylvain thenault <sylvain.thenault@logilab.fr>2009-03-24 16:18:18 +0100
committersylvain thenault <sylvain.thenault@logilab.fr>2009-03-24 16:18:18 +0100
commit2f9539af8c85fce925842b6932c3a5ebc69c5362 (patch)
tree6dc53cd07d2f43e5a702c33820fa8ed8ac0c6faa
parent68d8b7ba338b4d17c3b77dd8df9dae58835e3e32 (diff)
downloadlogilab-common-2f9539af8c85fce925842b6932c3a5ebc69c5362.tar.gz
backport Sandro Tosi 0.38.1-1 changes
-rw-r--r--debian/changelog27
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules24
3 files changed, 37 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index 3579ede..f2c9d10 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,20 +1,29 @@
-logilab-common (0.38.1-1) UNRELEASED; urgency=low
+logilab-common (0.38.1-1) unstable; urgency=low
- * new upstream release
+ * New upstream release
+ * debian/{control, rules}
+ - move from python-central to python-support
+ * debian/control
+ - bump Standard-Version to 3.8.1 (no changes needed)
+
+ -- Sandro Tosi <morph@debian.org> Tue, 17 Mar 2009 16:26:15 +0100
+
+logilab-common (0.38.0-1) unstable; urgency=low
+
+ * New upstream release
* debian/watch
- added opts=pasv to parse correctly remote ftp site
- bump version to 3
- removed path to debian package and command to execute after download
* debian/copyright
- updated upstream copyright information
+ * debian/rules
+ - added test execution at build-time, simulating "logilab" is a real
+ package; thanks Piotr!
+ - using --root at install-time
+ - build can't be used as dh_clean call (it's a dir), restored 'rm -rf'
- -- Sandro Tosi <morph@debian.org> Sun, 01 Feb 2009 18:08:57 +0100
-
-logilab-common (0.38.0-1) unstable; urgency=low
-
- * new upstream release
-
- -- Sylvain Thénault <sylvain.thenault@logilab.fr> Mon, 26 Jan 2009 15:03:27 +0100
+ -- Sandro Tosi <morph@debian.org> Thu, 05 Feb 2009 00:53:24 +0100
logilab-common (0.37.2-2) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 038ff71..69ef176 100644
--- a/debian/control
+++ b/debian/control
@@ -4,9 +4,9 @@ Priority: optional
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders: David Douard <david.douard@logilab.fr>, Fabrice Douchant <fabrice.douchant@logilab.fr>, Alexandre Fayolle <afayolle@debian.org>, Sandro Tosi <morph@debian.org>
Build-Depends: debhelper (>= 5.0.38), python (>= 2.3.5-7)
-Build-Depends-Indep: python-central (>=0.5.6), python-epydoc, graphviz
+Build-Depends-Indep: python-support, python-epydoc, graphviz
XS-Python-Version: all
-Standards-Version: 3.8.0
+Standards-Version: 3.8.1
Homepage: http://www.logilab.org/project/logilab-common
Vcs-Svn: svn://svn.debian.org/svn/python-modules/packages/logilab-common/trunk/
Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/logilab-common/trunk/
diff --git a/debian/rules b/debian/rules
index e15c1e9..dac6f39 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,16 @@ build-stamp:
dh_testdir
# python module build
- python setup.py -q build
+ NO_SETUPTOOLS=1 python setup.py -q build
+
+ # run tests
+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+ # we need this hack because we have to import "logilab.common.pytest"
+ # but since it's a namespace package, we need to "simulate" it
+ touch $(CURDIR)/build/lib/logilab/__init__.py
+ -PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-2.5/pytest
+ rm -f $(CURDIR)/build/lib/logilab/__init__.py
+endif
# build doc
$(MAKE) -C doc
@@ -30,11 +39,13 @@ clean:
# clean doc
$(MAKE) -C doc clean
- python setup.py clean
+ NO_SETUPTOOLS=1 python setup.py clean
+
+ [ ! -d build ] || rm -rf build
find . -name "*.pyc" -delete
- dh_clean build-stamp build
+ dh_clean build-stamp
install: build
dh_testdir
@@ -42,9 +53,9 @@ install: build
dh_clean -k
dh_installdirs
- python setup.py -q install --no-compile --prefix=debian/python-logilab-common/usr/ --install-headers=debian/python-logilab-common/usr/include/ --install-scripts=debian/python-logilab-common/usr/bin
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile --root=debian/python-logilab-common/ --install-headers=usr/include/ --install-scripts=usr/bin/
- # remove test directory (installed in in the doc directory)
+ # remove test directory
rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test
# Build architecture-independent files here.
@@ -52,7 +63,7 @@ binary-indep: build install
dh_testdir
dh_testroot
dh_install -i
- dh_pycentral -i
+ dh_pysupport -i
dh_installchangelogs -i ChangeLog
dh_installexamples -i
dh_installdocs -i README doc/apidoc/
@@ -69,4 +80,3 @@ binary-arch:
binary: binary-indep
.PHONY: build clean binary binary-indep binary-arch
-