summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Jehannet <julien.jehannet@logilab.fr>2010-05-21 11:42:35 +0200
committerJulien Jehannet <julien.jehannet@logilab.fr>2010-05-21 11:42:35 +0200
commitd1ccb0267612d42d78d8f5c3db9ac8d6123bc400 (patch)
tree07e744bf3ddda1f1f04d6a30d678cdf36e4946f9
parentfcb1ab096614b155ddb35b7c6b0afb8e3ba6b9b7 (diff)
parent4ca8d7b3bd503943207a71772aa600385754cc9c (diff)
downloadlogilab-common-d1ccb0267612d42d78d8f5c3db9ac8d6123bc400.tar.gz
(merge: __pkginfo__)
-rw-r--r--README14
-rw-r--r--__pkginfo__.py25
-rw-r--r--debian/control4
-rw-r--r--debugger.py1
-rw-r--r--setup.py18
5 files changed, 29 insertions, 33 deletions
diff --git a/README b/README
index 55b51ab..ca05a6d 100644
--- a/README
+++ b/README
@@ -12,6 +12,20 @@ It is released under the GNU Public License.
There is no documentation available yet but the source code should be
clean and well documented.
+Designed to ease:
+
+* handling command line options and configuration files
+* writing interactive command line tools
+* manipulation files and character strings
+* interfacing to OmniORB
+* generating SQL queries
+* running unit tests
+* manipulating tree structures
+* generating text and HTML reports
+* logging
+* parsing XML processing instructions
+* more...
+
Installation
------------
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 52de2cf..6a8fde0 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -20,34 +20,17 @@ __docformat__ = "restructuredtext en"
distname = 'logilab-common'
modname = 'common'
+
numversion = (0, 50, 2)
version = '.'.join([str(num) for num in numversion])
-copyright = '2003-2010 LOGILAB S.A. (Paris, FRANCE), all rights reserved.'
+
+copyright = 'Copyright (c) 2003-2010 LOGILAB S.A. (Paris, FRANCE), all rights reserved.'
license = 'LGPL' # 2.1 or later
author = "Logilab"
author_email = "devel@logilab.fr"
-short_desc = "useful miscellaneous modules used by Logilab projects"
-
-long_desc = """logilab-common is a collection of low-level Python packages and \
-modules,
- designed to ease:
- * handling command line options and configuration files
- * writing interactive command line tools
- * manipulation files and character strings
- * interfacing to OmniORB
- * generating SQL queries
- * running unit tests
- * manipulating tree structures
- * accessing RDBMS (currently postgreSQL, mysql and sqlite)
- * generating text and HTML reports
- * logging
- * parsing XML processing instructions
- * more...
-"""
-
-
+description = "collection of low-level Python packages and modules used by Logilab projects"
web = "http://www.logilab.org/project/%s" % distname
ftp = "ftp://ftp.logilab.org/pub/%s" % modname
mailinglist = "mailto://python-projects@lists.logilab.org"
diff --git a/debian/control b/debian/control
index 5c3d03f..f3f34ff 100644
--- a/debian/control
+++ b/debian/control
@@ -8,8 +8,8 @@ Uploaders: David Douard <david.douard@logilab.fr>,
Dorothe Sénéchal <dorothee.senechal@logilab.fr>,
Adrien Di Mascio <Adrien.DiMascio@logilab.fr>,
Nicolas Chauvat <nicolas.chauvat@logilab.fr>
-Build-Depends: debhelper (>= 5.0.38), python (>= 2.4.6-2), python-egenix-mxdatetime
-Build-Depends-Indep: python-support, python-epydoc, graphviz
+Build-Depends: debhelper (>= 5.0.38), python (>= 2.4.6-2)
+Build-Depends-Indep: python-support, python-epydoc, graphviz, python-egenix-mxdatetime
XS-Python-Version: all
Standards-Version: 3.8.2
Homepage: http://www.logilab.org/project/logilab-common
diff --git a/debugger.py b/debugger.py
index 515a94e..03c1683 100644
--- a/debugger.py
+++ b/debugger.py
@@ -199,7 +199,6 @@ class Debugger(Pdb):
do_o = do_open
-
def pm():
"""use our custom debugger"""
dbg = Debugger(sys.last_traceback)
diff --git a/setup.py b/setup.py
index 1aca654..905895a 100644
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ except ImportError:
sys.modules.pop('__pkginfo__', None)
# import required features
-from __pkginfo__ import modname, version, license, short_desc, long_desc, \
+from __pkginfo__ import modname, version, license, description, \
web, author, author_email
# import optional features
import __pkginfo__
@@ -57,11 +57,13 @@ STD_BLACKLIST = ('CVS', '.svn', '.hg', 'debian', 'dist', 'build')
IGNORED_EXTENSIONS = ('.pyc', '.pyo', '.elc', '~')
-
+if exists('README'):
+ long_description = file('README').read()
+else:
+ long_description = ''
def ensure_scripts(linux_scripts):
- """
- Creates the proper script names required for each platform
+ """Creates the proper script names required for each platform
(taken from 4Suite)
"""
from distutils import util
@@ -71,10 +73,8 @@ def ensure_scripts(linux_scripts):
scripts_ = linux_scripts
return scripts_
-
def get_packages(directory, prefix):
- """return a list of subpackages for the given directory
- """
+ """return a list of subpackages for the given directory"""
result = []
for package in os.listdir(directory):
absfile = join(directory, package)
@@ -185,8 +185,8 @@ def install(**kwargs):
return setup(name = distname,
version = version,
license = license,
- description = short_desc,
- long_description = long_desc,
+ description = description,
+ long_description = long_description,
author = author,
author_email = author_email,
url = web,