summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain <syt@logilab.fr>2006-12-19 12:47:41 +0100
committerSylvain <syt@logilab.fr>2006-12-19 12:47:41 +0100
commit44a3bfcf488d55878e54d41d5163369889a3c534 (patch)
tree255405864aeac0d9f4b335a90de137ac3201b143
parent463df3b38f44ad1806ad05b4b45ebffa2d551fea (diff)
downloadlogilab-common-44a3bfcf488d55878e54d41d5163369889a3c534.tar.gz
-rw-r--r--ChangeLog26
-rw-r--r--__pkginfo__.py2
-rw-r--r--db.py10
-rw-r--r--debian/changelog6
4 files changed, 30 insertions, 14 deletions
diff --git a/ChangeLog b/ChangeLog
index e290b8a..f004176 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,7 +1,7 @@
ChangeLog for logilab.common
============================
- --
+2006-12-19 -- 0.21.1
* tree: make Node iterable (iter on its children)
* configuration: fix #3197 (OptionsManagerMixin __init__ isn't passing
correctly its "version" argument)
@@ -21,20 +21,20 @@ ChangeLog for logilab.common
functions in favor of new function shellutils.find
* mark the following modules for deprecation, they will be removed in a
near version:
- * astutils: moved to astng
- * bind (never been used)
- * html: deprecated
- * logger/logservice: use logging module
- * monclient/monserver (not used anymore)
- * patricia (never been used)
- * twisted_distutils (not used anymore)
+ * astutils: moved to astng
+ * bind (never been used)
+ * html: deprecated
+ * logger/logservice: use logging module
+ * monclient/monserver (not used anymore)
+ * patricia (never been used)
+ * twisted_distutils (not used anymore)
* removed the following functions/methods which have been deprecated for a
while now:
- * modutils.load_module_from_parts
- * textutils.searchall
- * tree.Node.leafs
- * fileutils.get_by_ext, filetutils.get_mode, fileutils.ensure_mode
- * umessage: more robust charset handling
+ * modutils.load_module_from_parts
+ * textutils.searchall
+ * tree.Node.leafs
+ * fileutils.get_by_ext, filetutils.get_mode, fileutils.ensure_mode
+ * umessage: more robust charset handling
2006-11-03 -- 0.20.2
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 7980068..6776556 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -17,7 +17,7 @@
distname = 'logilab-common'
modname = 'common'
-numversion = (0, 21, 0)
+numversion = (0, 21, 1)
version = '.'.join([str(num) for num in numversion])
license = 'GPL'
diff --git a/db.py b/db.py
index fea5355..604da80 100644
--- a/db.py
+++ b/db.py
@@ -230,6 +230,16 @@ class _Psycopg2Adapter(_PsycopgAdapter):
extensions.register_type(psycopg2._psycopg.MXINTERVAL)
extensions.register_type(psycopg2._psycopg.MXDATE)
extensions.register_type(psycopg2._psycopg.MXTIME)
+ # StringIO/cStringIO adaptation
+ # XXX (syt) todo, see my december discussion on the psycopg2 list
+ # for a working solution
+ #def adapt_stringio(stringio):
+ # print 'ADAPTING', stringio
+ # return psycopg2.Binary(stringio.getvalue())
+ #import StringIO
+ #extensions.register_adapter(StringIO.StringIO, adapt_stringio)
+ #import cStringIO
+ #extensions.register_adapter(cStringIO.StringIO, adapt_stringio)
class _PgsqlAdapter(DBAPIAdapter):
diff --git a/debian/changelog b/debian/changelog
index 105f889..3053eaa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+logilab-common (0.21.1-1) unstable; urgency=low
+
+ * new upstream release
+
+ -- Sylvain Thénault <sylvain.thenault@logilab.fr> Tue, 19 Dec 2006 12:46:10 +0100
+
logilab-common (0.21.0-2) unstable; urgency=low
* Debian upload of the new release