summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJulien Jehannet <julien.jehannet@logilab.fr>2009-09-15 15:01:53 +0200
committerJulien Jehannet <julien.jehannet@logilab.fr>2009-09-15 15:01:53 +0200
commit028ddb178ec0276bd03b4b9694c3faf1d715a9dd (patch)
treead716de21d565adb568366c0f5ad472aae5f3395 /debian
parent31f761f57d265e133233b7e46d5cee6df2c71b13 (diff)
downloadlogilab-common-028ddb178ec0276bd03b4b9694c3faf1d715a9dd.tar.gz
[C] debian: refactoring and merge specific cases into unique debian directory
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index c0bd75a..e1acbe2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,20 +10,21 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+PY_VERSION:=$(shell pyversions -vd)
build: build-stamp
build-stamp:
dh_testdir
# python module build
- NO_SETUPTOOLS=1 python setup.py -q build
+ NO_SETUPTOOLS=1 python setup.py -q build --build-purelib=build/lib
# run tests
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
# we need this hack because we have to import "logilab.common.pytest"
# but since it's a namespace package, we need to "simulate" it
touch $(CURDIR)/build/lib/logilab/__init__.py
- -PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-2.5/pytest
+ -PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-$(PY_VERSION)/pytest
rm -f $(CURDIR)/build/lib/logilab/__init__.py
endif
@@ -53,7 +54,7 @@ install: build
dh_clean -k
dh_installdirs
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ NO_SETUPTOOLS=1 python setup.py -q install --prefix=/usr --no-compile \
--root=$(CURDIR)/debian/python-logilab-common/ \
--install-layout=deb
# remove test directory