summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorLaurent Peuch <cortex@worlddomination.be>2019-06-20 00:35:44 +0200
committerLaurent Peuch <cortex@worlddomination.be>2019-06-20 00:35:44 +0200
commit71cd4043ac625b439b032773a293a767b43685f2 (patch)
tree8942b17287bce777328225821bb167dccb023203 /docs
parenta3fa0a553f560b6c4396a7e806707ddd0cddcdf8 (diff)
downloadlogilab-common-71cd4043ac625b439b032773a293a767b43685f2.tar.gz
[doc] rename doc/ into docs/
readthedocs likes documentation to be in a docS folder.
Diffstat (limited to 'docs')
-rw-r--r--docs/Makefile19
-rw-r--r--docs/conf.py185
-rw-r--r--docs/index.rst29
-rw-r--r--docs/logilab-pytest.154
-rw-r--r--docs/logilab.common.rst351
-rw-r--r--docs/logilab.common.ureports.rst48
-rw-r--r--docs/logilab.rst17
-rw-r--r--docs/make.bat35
-rw-r--r--docs/modules.rst7
-rw-r--r--docs/requirements-doc.txt2
10 files changed, 747 insertions, 0 deletions
diff --git a/docs/Makefile b/docs/Makefile
new file mode 100644
index 0000000..298ea9e
--- /dev/null
+++ b/docs/Makefile
@@ -0,0 +1,19 @@
+# Minimal makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXOPTS =
+SPHINXBUILD = sphinx-build
+SOURCEDIR = .
+BUILDDIR = _build
+
+# Put it first so that "make" without argument is like "make help".
+help:
+ @$(SPHINXBUILD) -M help "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
+
+.PHONY: help Makefile
+
+# Catch-all target: route all unknown targets to Sphinx using the new
+# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).
+%: Makefile
+ @$(SPHINXBUILD) -M $@ "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O) \ No newline at end of file
diff --git a/docs/conf.py b/docs/conf.py
new file mode 100644
index 0000000..1e8b076
--- /dev/null
+++ b/docs/conf.py
@@ -0,0 +1,185 @@
+# -*- coding: utf-8 -*-
+#
+# Configuration file for the Sphinx documentation builder.
+#
+# This file does only contain a selection of the most common options. For a
+# full list see the documentation:
+# http://www.sphinx-doc.org/en/master/config
+
+# -- Path setup --------------------------------------------------------------
+
+# If extensions (or modules to document with autodoc) are in another directory,
+# add these directories to sys.path here. If the directory is relative to the
+# documentation root, use os.path.abspath to make it absolute, like shown here.
+
+import os
+import sys
+sys.path.insert(0, os.path.abspath('..'))
+
+
+# -- Project information -----------------------------------------------------
+
+project = u'logilab common'
+copyright = u'2019, Logilab'
+author = u'Logilab'
+
+# The short X.Y version
+version = u''
+# The full version, including alpha/beta/rc tags
+release = u''
+
+
+# -- General configuration ---------------------------------------------------
+
+# If your documentation needs a minimal Sphinx version, state it here.
+#
+# needs_sphinx = '1.0'
+
+# Add any Sphinx extension module names here, as strings. They can be
+# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom
+# ones.
+extensions = [
+ 'sphinx.ext.autodoc',
+ 'sphinx.ext.intersphinx',
+ 'sphinx.ext.coverage',
+ 'sphinx.ext.viewcode',
+]
+
+# Add any paths that contain templates here, relative to this directory.
+templates_path = ['_templates']
+
+# The suffix(es) of source filenames.
+# You can specify multiple suffix as a list of string:
+#
+# source_suffix = ['.rst', '.md']
+source_suffix = '.rst'
+
+# The master toctree document.
+master_doc = 'index'
+
+# The language for content autogenerated by Sphinx. Refer to documentation
+# for a list of supported languages.
+#
+# This is also used if you do content translation via gettext catalogs.
+# Usually you set "language" from the command line for these cases.
+language = None
+
+# List of patterns, relative to source directory, that match files and
+# directories to ignore when looking for source files.
+# This pattern also affects html_static_path and html_extra_path.
+exclude_patterns = [u'_build', 'Thumbs.db', '.DS_Store']
+
+# The name of the Pygments (syntax highlighting) style to use.
+pygments_style = None
+
+
+# -- Options for HTML output -------------------------------------------------
+
+# The theme to use for HTML and HTML Help pages. See the documentation for
+# a list of builtin themes.
+#
+html_theme = 'alabaster'
+
+# Theme options are theme-specific and customize the look and feel of a theme
+# further. For a list of options available for each theme, see the
+# documentation.
+#
+# html_theme_options = {}
+
+# Add any paths that contain custom static files (such as style sheets) here,
+# relative to this directory. They are copied after the builtin static files,
+# so a file named "default.css" will overwrite the builtin "default.css".
+html_static_path = ['_static']
+
+# Custom sidebar templates, must be a dictionary that maps document names
+# to template names.
+#
+# The default sidebars (for documents that don't match any pattern) are
+# defined by theme itself. Builtin themes are using these templates by
+# default: ``['localtoc.html', 'relations.html', 'sourcelink.html',
+# 'searchbox.html']``.
+#
+# html_sidebars = {}
+
+
+# -- Options for HTMLHelp output ---------------------------------------------
+
+# Output file base name for HTML help builder.
+htmlhelp_basename = 'logilabcommondoc'
+
+
+# -- Options for LaTeX output ------------------------------------------------
+
+latex_elements = {
+ # The paper size ('letterpaper' or 'a4paper').
+ #
+ # 'papersize': 'letterpaper',
+
+ # The font size ('10pt', '11pt' or '12pt').
+ #
+ # 'pointsize': '10pt',
+
+ # Additional stuff for the LaTeX preamble.
+ #
+ # 'preamble': '',
+
+ # Latex figure (float) alignment
+ #
+ # 'figure_align': 'htbp',
+}
+
+# Grouping the document tree into LaTeX files. List of tuples
+# (source start file, target name, title,
+# author, documentclass [howto, manual, or own class]).
+latex_documents = [
+ (master_doc, 'logilabcommon.tex', u'logilab common Documentation',
+ u'Logilab', 'manual'),
+]
+
+
+# -- Options for manual page output ------------------------------------------
+
+# One entry per manual page. List of tuples
+# (source start file, name, description, authors, manual section).
+man_pages = [
+ (master_doc, 'logilabcommon', u'logilab common Documentation',
+ [author], 1)
+]
+
+
+# -- Options for Texinfo output ----------------------------------------------
+
+# Grouping the document tree into Texinfo files. List of tuples
+# (source start file, target name, title, author,
+# dir menu entry, description, category)
+texinfo_documents = [
+ (master_doc, 'logilabcommon', u'logilab common Documentation',
+ author, 'logilabcommon', 'One line description of project.',
+ 'Miscellaneous'),
+]
+
+
+# -- Options for Epub output -------------------------------------------------
+
+# Bibliographic Dublin Core info.
+epub_title = project
+
+# The unique identifier of the text. This can be a ISBN number
+# or the project homepage.
+#
+# epub_identifier = ''
+
+# A unique identification for the text.
+#
+# epub_uid = ''
+
+# A list of files that should not be packed into the epub file.
+epub_exclude_files = ['search.html']
+
+
+# -- Extension configuration -------------------------------------------------
+
+# -- Options for intersphinx extension ---------------------------------------
+
+# Example configuration for intersphinx: refer to the Python standard library.
+intersphinx_mapping = {'https://docs.python.org/': None}
diff --git a/docs/index.rst b/docs/index.rst
new file mode 100644
index 0000000..47d17ab
--- /dev/null
+++ b/docs/index.rst
@@ -0,0 +1,29 @@
+.. logilab common documentation master file, created by
+ sphinx-quickstart on Thu May 23 03:36:04 2019.
+ You can adapt this file completely to your liking, but it should at least
+ contain the root `toctree` directive.
+
+.. include:: ../README
+
+.. _Sphinx: http://sphinx.pocoo.org/
+.. _`unittest2`: http://pypi.python.org/pypi/unittest2
+.. _`discover`: http://pypi.python.org/pypi/discover
+.. _`zope.interface`: http://pypi.python.org/pypi/zope.interface
+
+Reference
+=========
+
+.. toctree::
+ :maxdepth: 2
+ :caption: Contents:
+
+ logilab.common
+ logilab.common.ureports
+
+
+Indices and tables
+==================
+
+* :ref:`genindex`
+* :ref:`modindex`
+* :ref:`search`
diff --git a/docs/logilab-pytest.1 b/docs/logilab-pytest.1
new file mode 100644
index 0000000..51aec2e
--- /dev/null
+++ b/docs/logilab-pytest.1
@@ -0,0 +1,54 @@
+.TH logilab-pytest "1" "January 2008" logilab-pytest
+.SH NAME
+.B logilab-pytest
+\- run python unit tests
+
+.SH SYNOPSIS
+usage: logilab-pytest [OPTIONS] [testfile [testpattern]]
+.PP
+examples:
+.PP
+logilab-pytest path/to/mytests.py
+logilab-pytest path/to/mytests.py TheseTests
+logilab-pytest path/to/mytests.py TheseTests.test_thisone
+.PP
+logilab-pytest one (will run both test_thisone and test_thatone)
+logilab-pytest path/to/mytests.py \fB\-s\fR not (will skip test_notthisone)
+.PP
+logilab-pytest \fB\-\-coverage\fR test_foo.py
+.IP
+(only if logilab.devtools is available)
+.SS "options:"
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+show this help message and exit
+.TP
+\fB\-t\fR TESTDIR
+directory where the tests will be found
+.TP
+\fB\-d\fR
+enable design\-by\-contract
+.TP
+\fB\-v\fR, \fB\-\-verbose\fR
+Verbose output
+.TP
+\fB\-i\fR, \fB\-\-pdb\fR
+Enable test failure inspection (conflicts with
+\fB\-\-coverage\fR)
+.TP
+\fB\-x\fR, \fB\-\-exitfirst\fR
+Exit on first failure (only make sense when logilab-pytest run
+one test file)
+.TP
+\fB\-s\fR SKIPPED, \fB\-\-skip\fR=\fISKIPPED\fR
+test names matching this name will be skipped to skip
+several patterns, use commas
+.TP
+\fB\-q\fR, \fB\-\-quiet\fR
+Minimal output
+.TP
+\fB\-P\fR PROFILE, \fB\-\-profile\fR=\fIPROFILE\fR
+Profile execution and store data in the given file
+.TP
+\fB\-\-coverage\fR
+run tests with pycoverage (conflicts with \fB\-\-pdb\fR)
diff --git a/docs/logilab.common.rst b/docs/logilab.common.rst
new file mode 100644
index 0000000..da20e6d
--- /dev/null
+++ b/docs/logilab.common.rst
@@ -0,0 +1,351 @@
+logilab.common package
+======================
+
+Subpackages
+-----------
+
+.. toctree::
+
+ logilab.common.ureports
+
+Submodules
+----------
+
+.. _cache:
+
+logilab.common.cache module
+---------------------------
+
+.. automodule:: logilab.common.cache
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _changelog:
+
+logilab.common.changelog module
+-------------------------------
+
+.. automodule:: logilab.common.changelog
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _clcommands:
+
+logilab.common.clcommands module
+--------------------------------
+
+.. automodule:: logilab.common.clcommands
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _compat:
+
+logilab.common.compat module
+----------------------------
+
+.. automodule:: logilab.common.compat
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _configuration:
+
+logilab.common.configuration module
+-----------------------------------
+
+.. automodule:: logilab.common.configuration
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _daemon:
+
+logilab.common.daemon module
+----------------------------
+
+.. automodule:: logilab.common.daemon
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _date:
+
+logilab.common.date module
+--------------------------
+
+.. automodule:: logilab.common.date
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _debugger:
+
+logilab.common.debugger module
+------------------------------
+
+.. automodule:: logilab.common.debugger
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _decorators:
+
+logilab.common.decorators module
+--------------------------------
+
+.. automodule:: logilab.common.decorators
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _deprecation:
+
+logilab.common.deprecation module
+---------------------------------
+
+.. automodule:: logilab.common.deprecation
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _fileutils:
+
+logilab.common.fileutils module
+-------------------------------
+
+.. automodule:: logilab.common.fileutils
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _graph:
+
+logilab.common.graph module
+---------------------------
+
+.. automodule:: logilab.common.graph
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _interface:
+
+logilab.common.interface module
+-------------------------------
+
+.. automodule:: logilab.common.interface
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _logging_ext:
+
+logilab.common.logging\_ext module
+----------------------------------
+
+.. automodule:: logilab.common.logging_ext
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _modutils:
+
+logilab.common.modutils module
+------------------------------
+
+.. automodule:: logilab.common.modutils
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _optik_ext:
+
+logilab.common.optik\_ext module
+--------------------------------
+
+.. automodule:: logilab.common.optik_ext
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _optparser:
+
+logilab.common.optparser module
+-------------------------------
+
+.. automodule:: logilab.common.optparser
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _proc:
+
+logilab.common.proc module
+--------------------------
+
+.. automodule:: logilab.common.proc
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _pytest:
+
+logilab.common.pytest module
+----------------------------
+
+.. automodule:: logilab.common.pytest
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _registry:
+
+logilab.common.registry module
+------------------------------
+
+.. automodule:: logilab.common.registry
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _shellutils:
+
+logilab.common.shellutils module
+--------------------------------
+
+.. automodule:: logilab.common.shellutils
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _sphinx_ext:
+
+logilab.common.sphinx\_ext module
+---------------------------------
+
+.. automodule:: logilab.common.sphinx_ext
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _sphinxutils:
+
+logilab.common.sphinxutils module
+---------------------------------
+
+.. automodule:: logilab.common.sphinxutils
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _table:
+
+logilab.common.table module
+---------------------------
+
+.. automodule:: logilab.common.table
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _tasksqueue:
+
+logilab.common.tasksqueue module
+--------------------------------
+
+.. automodule:: logilab.common.tasksqueue
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _testlib:
+
+logilab.common.testlib module
+-----------------------------
+
+.. automodule:: logilab.common.testlib
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _textutils:
+
+logilab.common.textutils module
+-------------------------------
+
+.. automodule:: logilab.common.textutils
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _tree:
+
+logilab.common.tree module
+--------------------------
+
+.. automodule:: logilab.common.tree
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _umessage:
+
+logilab.common.umessage module
+------------------------------
+
+.. automodule:: logilab.common.umessage
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _urllib2ext:
+
+logilab.common.urllib2ext module
+--------------------------------
+
+.. automodule:: logilab.common.urllib2ext
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _vcgutils:
+
+logilab.common.vcgutils module
+------------------------------
+
+.. automodule:: logilab.common.vcgutils
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _visitor:
+
+logilab.common.visitor module
+-----------------------------
+
+.. automodule:: logilab.common.visitor
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+.. _xmlutils:
+
+logilab.common.xmlutils module
+------------------------------
+
+.. automodule:: logilab.common.xmlutils
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+
+Module contents
+---------------
+
+.. automodule:: logilab.common
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/docs/logilab.common.ureports.rst b/docs/logilab.common.ureports.rst
new file mode 100644
index 0000000..321c422
--- /dev/null
+++ b/docs/logilab.common.ureports.rst
@@ -0,0 +1,48 @@
+.. _ureports:
+
+logilab.common.ureports package
+===============================
+
+Submodules
+----------
+
+logilab.common.ureports.docbook\_writer module
+----------------------------------------------
+
+.. automodule:: logilab.common.ureports.docbook_writer
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+logilab.common.ureports.html\_writer module
+-------------------------------------------
+
+.. automodule:: logilab.common.ureports.html_writer
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+logilab.common.ureports.nodes module
+------------------------------------
+
+.. automodule:: logilab.common.ureports.nodes
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+logilab.common.ureports.text\_writer module
+-------------------------------------------
+
+.. automodule:: logilab.common.ureports.text_writer
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+
+Module contents
+---------------
+
+.. automodule:: logilab.common.ureports
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/docs/logilab.rst b/docs/logilab.rst
new file mode 100644
index 0000000..3a6f400
--- /dev/null
+++ b/docs/logilab.rst
@@ -0,0 +1,17 @@
+logilab package
+===============
+
+Subpackages
+-----------
+
+.. toctree::
+
+ logilab.common
+
+Module contents
+---------------
+
+.. automodule:: logilab
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/docs/make.bat b/docs/make.bat
new file mode 100644
index 0000000..c4abe7e
--- /dev/null
+++ b/docs/make.bat
@@ -0,0 +1,35 @@
+ at ECHO OFF
+
+pushd %~dp0
+
+REM Command file for Sphinx documentation
+
+if "%SPHINXBUILD%" == "" (
+ set SPHINXBUILD=sphinx-build
+)
+set SOURCEDIR=.
+set BUILDDIR=_build
+
+if "%1" == "" goto help
+
+%SPHINXBUILD% >NUL 2>NUL
+if errorlevel 9009 (
+ echo.
+ echo.The 'sphinx-build' command was not found. Make sure you have Sphinx
+ echo.installed, then set the SPHINXBUILD environment variable to point
+ echo.to the full path of the 'sphinx-build' executable. Alternatively you
+ echo.may add the Sphinx directory to PATH.
+ echo.
+ echo.If you don't have Sphinx installed, grab it from
+ echo.http://sphinx-doc.org/
+ exit /b 1
+)
+
+%SPHINXBUILD% -M %1 %SOURCEDIR% %BUILDDIR% %SPHINXOPTS%
+goto end
+
+:help
+%SPHINXBUILD% -M help %SOURCEDIR% %BUILDDIR% %SPHINXOPTS%
+
+:end
+popd
diff --git a/docs/modules.rst b/docs/modules.rst
new file mode 100644
index 0000000..6b2ca27
--- /dev/null
+++ b/docs/modules.rst
@@ -0,0 +1,7 @@
+logilab
+=======
+
+.. toctree::
+ :maxdepth: 4
+
+ logilab
diff --git a/docs/requirements-doc.txt b/docs/requirements-doc.txt
new file mode 100644
index 0000000..06ba822
--- /dev/null
+++ b/docs/requirements-doc.txt
@@ -0,0 +1,2 @@
+sphinx
+kerberos