diff options
author | Julien Jehannet <julien.jehannet@logilab.fr> | 2010-03-22 14:00:19 +0100 |
---|---|---|
committer | Julien Jehannet <julien.jehannet@logilab.fr> | 2010-03-22 14:00:19 +0100 |
commit | b73d14a2863d191962a5d2dccb87377c99581d06 (patch) | |
tree | e3757ba8539af40ead428ed44de7d613d57d7288 /setup.py | |
parent | 0c698c256a87876757a4ec4752355a52912741cf (diff) | |
download | logilab-common-b73d14a2863d191962a5d2dccb87377c99581d06.tar.gz |
[B] setup.py: remove '--install-layout' option for python setup.py correctly
Use python version (<2.5.4) instead of distutils version to detect existence of 'install-layout' option and remove it accordingly.
This option was introduced in 2.5.3-1~exp1 but without distutils version upgrade that breaks installation in last 2.5 series.
The code is still necessary for lenny release and should be removed afterwards.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -176,8 +176,8 @@ def install(**kwargs): pass try: if not USE_SETUPTOOLS: - from distutils import __version__ as distutils_version - if tuple([int(x) for x in distutils_version.split('.')]) < (2, 5, 1): + # install-layout option was introduced in 2.5.3-1~exp1 + if sys.versioninfo < (2, 5, 4): sys.argv.remove('--install-layout=deb') print "W: remove '--install-layout=deb' option" except: |