summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLaurent Peuch <cortex@worlddomination.be>2020-07-07 18:49:26 +0200
committerLaurent Peuch <cortex@worlddomination.be>2020-07-07 18:49:26 +0200
commit1d77cfc704422ac16a6e8aa5ea0668e901d35000 (patch)
tree232f375ace1ebc547250ec14a73ca37b2fa88f82 /setup.py
parent30ee723e7b90d6e07368e08bb0c00cc46bd48976 (diff)
downloadlogilab-common-1d77cfc704422ac16a6e8aa5ea0668e901d35000.tar.gz
type: declare that logilab-common ship type annotations
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a577530..2108e40 100644
--- a/setup.py
+++ b/setup.py
@@ -47,6 +47,8 @@ setup(
# See https://pypi.python.org/pypi?%3Aaction=list_classifiers
classifiers=pkginfo["classifiers"],
packages=find_packages(exclude=["contrib", "docs", "test*"]),
+ package_data={"logilab.common": ["py.typed"]},
+ include_package_data=True,
namespace_packages=[pkginfo["subpackage_of"]],
python_requires=">=3.6",
install_requires=pkginfo["install_requires"],