summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2013-10-03 16:36:18 +0200
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2013-10-03 16:36:18 +0200
commit64aafff708367f5211b321d478bf2927728b2a4c (patch)
treed3927a1932e1e30fbdc40406cbd717c46d4bcdaa /setup.py
parent6d0d0982577adbc239abb29c6f2d87ca1e4b2782 (diff)
downloadlogilab-common-64aafff708367f5211b321d478bf2927728b2a4c.tar.gz
Backport fix done by Benedikt Morbach on pylint for python3 install on win32 platforms / cross compilation. Closes #180836
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 9ac5255..764651d 100644
--- a/setup.py
+++ b/setup.py
@@ -139,11 +139,12 @@ class MyBuildPy(build_py):
shutil.copytree(directory, dest)
if sys.version_info >= (3, 0):
# process manually python file in include_dirs (test data)
- from subprocess import check_call
+ from distutils.util import run_2to3
# brackets are NOT optional here for py3k compat
print('running 2to3 on', dest)
- # Needs `shell=True` to run on Windows.
- check_call(['2to3', '-wn', dest], shell=sys.platform=='win32')
+ run_2to3([dest])
+
+
def install(**kwargs):