diff options
author | Sylvain Th?nault <sylvain.thenault@logilab.fr> | 2010-02-27 14:32:13 +0100 |
---|---|---|
committer | Sylvain Th?nault <sylvain.thenault@logilab.fr> | 2010-02-27 14:32:13 +0100 |
commit | 1c8e6d5c9c8ef52ecaf8a96491714f13ff51ca98 (patch) | |
tree | adc6a2cc5b69e806cf190bcb395693de53427d64 /setup.py | |
parent | 9111b1556c6190a3932272edcb65a5446cd85df7 (diff) | |
download | logilab-common-1c8e6d5c9c8ef52ecaf8a96491714f13ff51ca98.tar.gz |
fix bad comparison of distutils version: comparing a list of string with a tuple of int...
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -177,7 +177,7 @@ def install(**kwargs): try: if not USE_SETUPTOOLS: from distutils import __version__ as distutils_version - if distutils_version.split('.') <= (2, 5, 1): + if tuple([int(x) for x in distutils_version.split('.')]) <= (2, 5, 1): sys.argv.remove('--install-layout=deb') print "W: remove '--install-layout=deb' option" except: |