summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--modutils.py8
-rw-r--r--setup.py7
-rw-r--r--shellutils.py4
3 files changed, 8 insertions, 11 deletions
diff --git a/modutils.py b/modutils.py
index c5260e3..4ab4656 100644
--- a/modutils.py
+++ b/modutils.py
@@ -311,7 +311,7 @@ def get_modules(package, src_directory, blacklist=STD_BLACKLIST):
-def get_module_files(src_directory, blacklist=('CVS', '.svn', '.hg', 'debian')):
+def get_module_files(src_directory, blacklist=STD_BLACKLIST):
"""given a package directory return a list of all available python
module's files in the package and its subpackages
@@ -319,10 +319,10 @@ def get_module_files(src_directory, blacklist=('CVS', '.svn', '.hg', 'debian')):
:param src_directory:
path of the directory corresponding to the package
- :type blacklist: list(str) or tuple(str)
+ :type blacklist: list or tuple
:param blacklist:
- optional list of files or directory to ignore, default to 'CVS',
- '.svn' and 'debian'
+ optional list of files or directory to ignore, default to the value of
+ `logilab.common.STD_BLACKLIST`
:rtype: list
:return:
diff --git a/setup.py b/setup.py
index 8a1d555..54a0def 100644
--- a/setup.py
+++ b/setup.py
@@ -17,10 +17,6 @@
# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
""" Generic Setup script, takes package info from __pkginfo__.py file """
-from __future__ import nested_scopes
-
-__revision__ = '$Id: setup.py,v 1.24 2006-04-10 15:12:53 syt Exp $'
-
import os
import sys
import shutil
@@ -58,6 +54,7 @@ try:
except ImportError:
ext_modules = None
+from __init__ import STD_BLACKLIST, IGNORED_EXTENSIONS
BASE_BLACKLIST = ('CVS', 'debian', 'dist', 'build', '__buildlog', '.svn')
IGNORED_EXTENSIONS = ('.pyc', '.pyo', '.elc')
@@ -92,7 +89,7 @@ def get_packages(directory, prefix):
return result
def export(from_dir, to_dir,
- blacklist=BASE_BLACKLIST,
+ blacklist=STD_BLACKLIST,
ignore_ext=IGNORED_EXTENSIONS):
"""make a mirror of from_dir in to_dir, omitting directories and files
listed in the black list
diff --git a/shellutils.py b/shellutils.py
index 8f7a5e9..fefd05c 100644
--- a/shellutils.py
+++ b/shellutils.py
@@ -83,8 +83,8 @@ def find(directory, exts, exclude=False, blacklist=STD_BLACKLIST):
:type blacklist: list or tuple
:param blacklist:
- optional list of files or directory to ignore, default to
- the value of `logilab.common.STD_BLACKLIST`
+ optional list of files or directory to ignore, default to the value of
+ `logilab.common.STD_BLACKLIST`
:rtype: list
:return: