summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--__pkginfo__.py2
-rw-r--r--debian/changelog8
-rw-r--r--debian/control4
-rw-r--r--debian/copyright3
-rwxr-xr-xdebian/rules4
5 files changed, 17 insertions, 4 deletions
diff --git a/__pkginfo__.py b/__pkginfo__.py
index e292fad..79aab83 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -8,7 +8,7 @@ __docformat__ = "restructuredtext en"
distname = 'logilab-common'
modname = 'common'
-numversion = (0, 41, 0)
+numversion = (0, 42, 0)
version = '.'.join([str(num) for num in numversion])
license = 'GPL'
diff --git a/debian/changelog b/debian/changelog
index c42a604..ab205a8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+logilab-common (0.42.0-1) unstable; urgency=low
+
+ * New upstream release
+ * debian/control: updated standards to 3.8.2
+ * debian/rules: adapted Julien Lavergne's python2.6 compatibility changes
+
+ -- Alexandre Fayolle <afayolle@debian.org> Thu, 02 Jul 2009 09:26:47 +0200
+
logilab-common (0.41.0-1) unstable; urgency=low
* new upstream release
diff --git a/debian/control b/debian/control
index 404501b..f4794ae 100644
--- a/debian/control
+++ b/debian/control
@@ -8,10 +8,10 @@ Uploaders: David Douard <david.douard@logilab.fr>,
Dorothe Sénéchal <dorothee.senechal@logilab.fr>,
Adrien Di Mascio <Adrien.DiMascio@logilab.fr>,
Nicolas Chauvat <nicolas.chauvat@logilab.fr>
-Build-Depends: debhelper (>= 5.0.38), python (>= 2.3.5-7)
+Build-Depends: debhelper (>= 5.0.38), python (>= 2.4)
Build-Depends-Indep: python-support, python-epydoc, graphviz
XS-Python-Version: all
-Standards-Version: 3.8.1
+Standards-Version: 3.8.2
Homepage: http://www.logilab.org/project/logilab-common
Vcs-Svn: svn://svn.debian.org/svn/python-modules/packages/logilab-common/trunk/
Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/logilab-common/trunk/
diff --git a/debian/copyright b/debian/copyright
index 2d9923b..b9565d0 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -17,3 +17,6 @@ License:
On Debian systems, the complete text of the GNU General Public License
Version 2 may be found in '/usr/share/common-licenses/GPL-2'.
+
+The Debian packaging is Copyright (C) 2008-2009, Sandro Tosi <morph@debian.org>
+and is licensed under the same terms as upstream code (see above).
diff --git a/debian/rules b/debian/rules
index 8f057e4..c0bd75a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -53,7 +53,9 @@ install: build
dh_clean -k
dh_installdirs
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile --root=debian/python-logilab-common/ --install-headers=usr/include/ --install-scripts=usr/bin/
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/python-logilab-common/ \
+ --install-layout=deb
# remove test directory
rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test