summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2019-08-01 12:13:22 -0400
committerMike Bayer <mike_mp@zzzcomputing.com>2019-08-01 12:13:22 -0400
commit7553fb8aa9c70739aac78a8548ad0600ac7032f1 (patch)
treedd58eea063a647c92ade5bb402e2f6ad0cd4fe3e
parent9cb8e09275a927bdbb738a865665178008e55937 (diff)
downloadmako-7553fb8aa9c70739aac78a8548ad0600ac7032f1.tar.gz
- formatting fixes for very old changelog versions
Change-Id: I831f8dff8bf7bd3c4f919f368e521624b591feb8
-rw-r--r--doc/build/changelog.rst23
1 files changed, 12 insertions, 11 deletions
diff --git a/doc/build/changelog.rst b/doc/build/changelog.rst
index 083158b..e15884c 100644
--- a/doc/build/changelog.rst
+++ b/doc/build/changelog.rst
@@ -1,3 +1,4 @@
+
=========
Changelog
=========
@@ -1023,7 +1024,7 @@ Older Versions
:tags:
:tickets: 148
- Fixed missing **extra collection in
+ Fixed missing \**extra collection in
setup.py which prevented setup.py
from running 2to3 on install.
@@ -1276,7 +1277,7 @@ Older Versions
The <%page args> tag can now be used in a base
inheriting template - the full set of render()
arguments are passed down through the inherits
- chain. Undeclared arguments go into **pageargs
+ chain. Undeclared arguments go into \**pageargs
as usual.
.. change::
@@ -1631,16 +1632,16 @@ Older Versions
added "attr" accessor to namespaces. Returns
attributes configured as module level attributes, i.e.
- within <%! %> sections. i.e.:
+ within <%! %> sections. i.e.::
- # somefile.html
- <%!
- foo = 27
- %>
+ # somefile.html
+ <%!
+ foo = 27
+ %>
- # some other template
- <%namespace name="myns" file="somefile.html"/>
- ${myns.attr.foo}
+ # some other template
+ <%namespace name="myns" file="somefile.html"/>
+ ${myns.attr.foo}
The slight backwards incompatibility here is, you
can't have namespace defs named "attr" since the
@@ -2034,7 +2035,7 @@ Older Versions
:tickets:
<%include> plus arguments is also programmatically available via
- self.include_file(<filename>, **kwargs)
+ self.include_file(<filename>, \**kwargs)
.. change::
:tags: