summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2018-01-16 13:21:29 -0500
committerMike Bayer <mike_mp@zzzcomputing.com>2018-01-16 13:21:29 -0500
commit200398c6fba989a7f72779e62fd326b28d12cdf2 (patch)
tree967ad1efe10b319f3d4b0b1c5fc23aef222c9fe1
parent7c58e12133262f8b070ce3d284f1742fad463bcd (diff)
parent741e63c3b83f454bb107a8e16284822e486b3fa8 (diff)
downloadmako-200398c6fba989a7f72779e62fd326b28d12cdf2.tar.gz
Merge remote-tracking branch 'github/pr/26'
-rw-r--r--.travis.yml17
-rw-r--r--tox.ini2
2 files changed, 10 insertions, 9 deletions
diff --git a/.travis.yml b/.travis.yml
index 69a61b8..3f0c218 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,11 +1,12 @@
language: python
-python: 2.7
-env:
- - TOX_ENV=py34
- - TOX_ENV=py33
- - TOX_ENV=py27
- - TOX_ENV=py26
+python:
+ - "3.6"
+ - "3.5"
+ - "3.4"
+ - "3.3"
+ - "2.7"
+ - "2.6"
install:
- - python -m pip install -U tox
+ - pip install -U tox-travis
script:
- - python -m tox -e $TOX_ENV
+ - tox
diff --git a/tox.ini b/tox.ini
index 19016de..816d8e6 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
# content of: tox.ini , put in same dir as setup.py
[tox]
minversion=1.8.dev1
-envlist = py{26,27,34,35}
+envlist = py{26,27,34,35,36}
[testenv]
cov_args=--cov=mako --cov-report term --cov-report xml