summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2013-08-03 13:17:52 -0400
committerMike Bayer <mike_mp@zzzcomputing.com>2013-08-03 13:17:52 -0400
commite14a686012cb55645982b8220b948dcadbbb2915 (patch)
tree4cad8fda93b22ab3b694f3e73209957f9c26733d
parent404275485f5263e60591edd254a614c73b039562 (diff)
downloadmako-e14a686012cb55645982b8220b948dcadbbb2915.tar.gz
- changelog
- guess this is 0.9.0
-rw-r--r--CHANGES8
-rw-r--r--mako/__init__.py2
-rw-r--r--test/templates/gettext.mako1
3 files changed, 10 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 929660a..fb83453 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,11 @@
+0.9.0
+- [bug] Fixed the babel plugin to properly interpret ${} sections
+ inside of a "call" tag, i.e. <%self:some_tag attr="${_('foo')}"/>.
+ Code that's subject to babel escapes in here needs to be
+ specified as a Python expression, not a literal. This change
+ is backwards incompatible vs. code that is relying upon a _('')
+ translation to be working within a call tag.
+
0.8.1
- [bug] Changed setup.py to skip installing markupsafe
if Python version is < 2.6 or is between 3.0 and
diff --git a/mako/__init__.py b/mako/__init__.py
index ab292df..2c0e26b 100644
--- a/mako/__init__.py
+++ b/mako/__init__.py
@@ -5,5 +5,5 @@
# the MIT License: http://www.opensource.org/licenses/mit-license.php
-__version__ = '0.8.1'
+__version__ = '0.9.0'
diff --git a/test/templates/gettext.mako b/test/templates/gettext.mako
index 85a7d8f..9c01b61 100644
--- a/test/templates/gettext.mako
+++ b/test/templates/gettext.mako
@@ -87,3 +87,4 @@ ${_(u'bar')}
</%self:block_tpl>
</%def>
+