summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2012-11-11 15:35:28 -0500
committerMike Bayer <mike_mp@zzzcomputing.com>2012-11-11 15:35:28 -0500
commit0e82d0c39d08f4f2885ea21db82f8845f42261be (patch)
treef0024d96de5303e264abb4090a955fdeda537670 /setup.py
parent800f3b13ed9c1ea52fbd6544dc902ebd7a721733 (diff)
downloadmako-0e82d0c39d08f4f2885ea21db82f8845f42261be.tar.gz
- guess you need compat.py huh
- dont need 2to3 - clean up some list() calls we dont need
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 2 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 07b350e..a6b9198 100644
--- a/setup.py
+++ b/setup.py
@@ -3,12 +3,6 @@ import os
import re
import sys
-extra = {}
-if sys.version_info >= (3, 0):
- extra.update(
- use_2to3=True,
- )
-
v = open(os.path.join(os.path.dirname(__file__), 'mako', '__init__.py'))
VERSION = re.compile(r".*__version__ = '(.*?)'", re.S).match(v.read()).group(1)
v.close()
@@ -47,7 +41,7 @@ setup(name='Mako',
entry_points="""
[python.templating.engines]
mako = mako.ext.turbogears:TGPlugin
-
+
[pygments.lexers]
mako = mako.ext.pygmentplugin:MakoLexer
html+mako = mako.ext.pygmentplugin:MakoHtmlLexer
@@ -57,6 +51,5 @@ setup(name='Mako',
[babel.extractors]
mako = mako.ext.babelplugin:extract
- """,
- **extra
+ """
)