summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2010-11-12 18:59:56 -0500
committerMike Bayer <mike_mp@zzzcomputing.com>2010-11-12 18:59:56 -0500
commit69cf8fef1550ffce4265a55009d17c5b6d0d5135 (patch)
tree2d27e343bd996df1b9c7ae37a9dadfefe27616d0 /setup.py
parentec3256d8b37eda6341d53d0a76a0f1a9ae6a739c (diff)
downloadmako-69cf8fef1550ffce4265a55009d17c5b6d0d5135.tar.gz
- Beaker is now part of "extras" in
setup.py instead of "install_requires". This to produce a lighter weight install for those who don't use the caching as well as to conform to Pyramid deployment practices. [ticket:154]
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c1c0805..c35fe53 100644
--- a/setup.py
+++ b/setup.py
@@ -47,9 +47,9 @@ ties to Python calling and scoping semantics.
test_suite = "nose.collector",
zip_safe=False,
install_requires=[
- 'Beaker>=1.1',
'MarkupSafe>=0.9.2',
],
+ extras_require = {'beaker':['Beaker>=1.1']},
entry_points="""
[python.templating.engines]
mako = mako.ext.turbogears:TGPlugin