summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py17
1 files changed, 3 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index a687f7e..fa05a27 100755
--- a/setup.py
+++ b/setup.py
@@ -1,23 +1,12 @@
#!/usr/bin/env python
-import os
-import re
+from setuptools import setup
-try:
- from setuptools import setup, Extension
-except ImportError:
- from distutils.core import setup, Extension
+import versiontools_support
-if os.path.isfile("MANIFEST"):
- os.unlink("MANIFEST")
-
-
-version = re.search('__version__ = "([^"]+)"',
- open("mocker.py").read()).group(1)
-
setup(
name="mocker",
- version=version,
+ version=":versiontools:mocker",
description="Graceful platform for test doubles in Python (mocks, stubs, fakes, and dummies).",
author="Gustavo Niemeyer",
author_email="gustavo@niemeyer.net",