summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ab56f44..9c4ffab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,7 +102,10 @@ if test "${PYTHONFRAMEWORKDIR}" = "no-framework"; then
from distutils import sysconfig; \
stdout.write(sysconfig.get_config_var("SYSLIBS"))'`
else
- if test -f "${PYTHONCFGDIR}/libpython${PYTHON_VERSION}.a"; then
+ if test "${PYTHON_VERSION}" != "2.3" && \
+ test "${PYTHON_VERSION}" != "2.4" && \
+ test "${PYTHON_VERSION}" != "2.5" && \
+ test -f "${PYTHONCFGDIR}/libpython${PYTHON_VERSION}.a"; then
LDFLAGS2="-L${PYTHONCFGDIR}"
LDLIBS1="-lpython${PYTHON_VERSION}"