summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorInada Naoki <songofacandy@gmail.com>2020-02-17 17:42:53 +0900
committerInada Naoki <songofacandy@gmail.com>2020-02-17 17:42:53 +0900
commit456e0ff96a7ebf866bb6fb742eef1b8baa465466 (patch)
treea78bf73439593f38f0ddf8a0f2c7583d6f3ccb87
parent12506d8d91ce5a7b76c2d8babe7e2d1e2851d3a2 (diff)
downloadmsgpack-python-456e0ff96a7ebf866bb6fb742eef1b8baa465466.tar.gz
Build manylinux2010 wheels on GitHub Actions.
-rw-r--r--.github/workflows/linux.yml31
-rw-r--r--Makefile8
-rw-r--r--docker/buildwheel.sh9
3 files changed, 43 insertions, 5 deletions
diff --git a/.github/workflows/linux.yml b/.github/workflows/linux.yml
new file mode 100644
index 0000000..dd1b33d
--- /dev/null
+++ b/.github/workflows/linux.yml
@@ -0,0 +1,31 @@
+name: Build Linux Wheels
+on:
+ push:
+ pull_request:
+ create:
+
+jobs:
+ build:
+ runs-on: ubuntu-latest
+ steps:
+ - name: Checkout
+ uses: actions/checkout@v1
+
+ - name: Cythonize
+ shell: bash
+ run: |
+ pip install -U pip
+ pip install -r requirements.txt
+ make cython
+ #python setup.py sdist
+
+ - name: amd64
+ shell: bash
+ run: |
+ make linux-wheel
+
+ - name: Upload Wheels
+ uses: actions/upload-artifact@v1
+ with:
+ name: linux-wheels
+ path: ./dist/wheelhouse/
diff --git a/Makefile b/Makefile
index b4749b3..c017b32 100644
--- a/Makefile
+++ b/Makefile
@@ -30,10 +30,10 @@ clean:
.PHONY: update-docker
update-docker:
- docker pull quay.io/pypa/manylinux1_i686
- docker pull quay.io/pypa/manylinux1_x86_64
+ docker pull quay.io/pypa/manylinux2010_i686
+ docker pull quay.io/pypa/manylinux2010_x86_64
.PHONY: linux-wheel
linux-wheel:
- docker run --rm -ti -v `pwd`:/project -w /project quay.io/pypa/manylinux1_i686 bash docker/buildwheel.sh
- docker run --rm -ti -v `pwd`:/project -w /project quay.io/pypa/manylinux1_x86_64 bash docker/buildwheel.sh
+ docker run --rm -ti -v `pwd`:/project -w /project quay.io/pypa/manylinux2010_i686 bash docker/buildwheel.sh
+ docker run --rm -ti -v `pwd`:/project -w /project quay.io/pypa/manylinux2010_x86_64 bash docker/buildwheel.sh
diff --git a/docker/buildwheel.sh b/docker/buildwheel.sh
index c953127..ca068849 100644
--- a/docker/buildwheel.sh
+++ b/docker/buildwheel.sh
@@ -10,5 +10,12 @@ echo "arch=$ARCH"
for V in "${PYTHON_VERSIONS[@]}"; do
PYBIN=/opt/python/$V/bin
rm -rf build/ # Avoid lib build by narrow Python is used by wide python
- $PYBIN/python setup.py bdist_wheel -p manylinux1_${ARCH}
+ #$PYBIN/python setup.py bdist_wheel -p manylinux2010_${ARCH}
+ $PYBIN/python setup.py bdist_wheel
+done
+
+cd dist
+for whl in *.whl; do
+ auditwheel repair "$whl"
+ rm "$whl"
done