summaryrefslogtreecommitdiff
path: root/docker/buildwheel.sh
diff options
context:
space:
mode:
Diffstat (limited to 'docker/buildwheel.sh')
-rw-r--r--docker/buildwheel.sh4
1 files changed, 3 insertions, 1 deletions
diff --git a/docker/buildwheel.sh b/docker/buildwheel.sh
index 89a2570..ff34139 100644
--- a/docker/buildwheel.sh
+++ b/docker/buildwheel.sh
@@ -7,10 +7,12 @@ set -e -x
ARCH=`uname -p`
echo "arch=$ARCH"
+ls /opt/python
+
for V in "${PYTHON_VERSIONS[@]}"; do
PYBIN=/opt/python/$V/bin
rm -rf build/ # Avoid lib build by narrow Python is used by wide python
- $PYBIN/python setup.py bdist_wheel
+ $PYBIN/python -m build -w
done
cd dist