summaryrefslogtreecommitdiff
path: root/MySQLdb/setup.py
diff options
context:
space:
mode:
authoradustman <adustman@9fc6cd9a-920d-0410-adcf-ac96716ed7e8>2002-07-02 03:55:58 +0000
committeradustman <adustman@9fc6cd9a-920d-0410-adcf-ac96716ed7e8>2002-07-02 03:55:58 +0000
commit6165f9d2f74c1b00ee482f0e948559811bb9be80 (patch)
treed60bde0ec9e1d769bd2f31329d58e19c6fabe78f /MySQLdb/setup.py
parentd259831f73b2a557fdef61c45e1f3f5250995669 (diff)
downloadmysqldb1-6165f9d2f74c1b00ee482f0e948559811bb9be80.tar.gz
FreeBSD/OpenBSD update
Diffstat (limited to 'MySQLdb/setup.py')
-rw-r--r--MySQLdb/setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/MySQLdb/setup.py b/MySQLdb/setup.py
index 77d3ebd..f5ffa47 100644
--- a/MySQLdb/setup.py
+++ b/MySQLdb/setup.py
@@ -51,6 +51,10 @@ extra_link_args = []
if sys.platform == "netbsd1":
include_dirs = ['/usr/pkg/include/mysql']
library_dirs = ['/usr/pkg/lib/mysql']
+elif sys.platform in ("freebsd4", "openbsd3"):
+ LOCALBASE = os.environ.get('LOCALBASE', '/usr/local')
+ include_dirs = ['%s/include/mysql' % LOCALBASE]
+ library_dirs = ['%s/lib/mysql' % LOCALBASE]
elif sys.platform == "sunos5": # Solaris 2.8 + gcc
runtime_library_dirs = ['/usr/local/lib:/usr/openwin/lib:/usr/dt/lib']
extra_compile_args = ["-fPIC"]