summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2018-05-17 23:43:45 -0400
committerSeth M Morton <seth.m.morton@gmail.com>2018-05-17 23:43:45 -0400
commit3f298f90e38fde352b365656402a61c4f89f4142 (patch)
tree6121a93c643591e4e5ff649c08c029cbfca98f4c
parent7c9c9f8bc564a75c92a5d757e79135cf9951c452 (diff)
downloadnatsort-3f298f90e38fde352b365656402a61c4f89f4142.tar.gz
Bump version: 5.3.1 → 5.3.25.3.2
-rw-r--r--docs/source/changelog.rst2
-rw-r--r--docs/source/conf.py2
-rw-r--r--natsort/_version.py2
-rw-r--r--setup.cfg82
-rw-r--r--setup.py2
5 files changed, 45 insertions, 45 deletions
diff --git a/docs/source/changelog.rst b/docs/source/changelog.rst
index 03667fb..6165651 100644
--- a/docs/source/changelog.rst
+++ b/docs/source/changelog.rst
@@ -10,7 +10,7 @@ Changelog
- Revert layout from src/natsort/ back to natsort/ to make user
testing simpler.
-05-14-2018 v. 5.3.1
+05-14-2018 v. 5.3.2
+++++++++++++++++++
- No bugfixes or features, just infrastructure and installation updates.
diff --git a/docs/source/conf.py b/docs/source/conf.py
index 05edb8f..da564ac 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -56,7 +56,7 @@ copyright = u'2014, Seth M. Morton'
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = '5.3.1'
+release = '5.3.2'
# The short X.Y version.
version = '.'.join(release.split('.')[0:2])
diff --git a/natsort/_version.py b/natsort/_version.py
index ddd231b..49e628c 100644
--- a/natsort/_version.py
+++ b/natsort/_version.py
@@ -6,4 +6,4 @@ from __future__ import (
absolute_import
)
-__version__ = '5.3.1'
+__version__ = '5.3.2'
diff --git a/setup.cfg b/setup.cfg
index e91267b..e9ca3d7 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,3 +1,9 @@
+[bumpversion]
+current_version = 5.3.2
+commit = True
+tag = True
+tag_name = {new_version}
+
[metadata]
author = Seth M. Morton
author_email = drtuba78@gmail.com
@@ -5,27 +11,27 @@ url = https://github.com/SethMMorton/natsort
description = Simple yet flexible natural sorting in Python.
long_description = file: README.rst
license = MIT
-classifiers =
- Development Status :: 5 - Production/Stable
- Intended Audience :: Developers
- Intended Audience :: Science/Research
- Intended Audience :: System Administrators
- Intended Audience :: Information Technology
- Intended Audience :: Financial and Insurance Industry
- Operating System :: OS Independent
- License :: OSI Approved :: MIT License
- Natural Language :: English
- Programming Language :: Python :: 2
- Programming Language :: Python :: 2.6
- Programming Language :: Python :: 2.7
- Programming Language :: Python :: 3
- Programming Language :: Python :: 3.3
- Programming Language :: Python :: 3.4
- Programming Language :: Python :: 3.5
- Programming Language :: Python :: 3.6
- Topic :: Scientific/Engineering :: Information Analysis
- Topic :: Utilities
- Topic :: Text Processing
+classifiers =
+ Development Status :: 5 - Production/Stable
+ Intended Audience :: Developers
+ Intended Audience :: Science/Research
+ Intended Audience :: System Administrators
+ Intended Audience :: Information Technology
+ Intended Audience :: Financial and Insurance Industry
+ Operating System :: OS Independent
+ License :: OSI Approved :: MIT License
+ Natural Language :: English
+ Programming Language :: Python :: 2
+ Programming Language :: Python :: 2.6
+ Programming Language :: Python :: 2.7
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3.3
+ Programming Language :: Python :: 3.4
+ Programming Language :: Python :: 3.5
+ Programming Language :: Python :: 3.6
+ Topic :: Scientific/Engineering :: Information Analysis
+ Topic :: Utilities
+ Topic :: Text Processing
[bdist_wheel]
universal = 1
@@ -33,12 +39,6 @@ universal = 1
[sdist]
formats = gztar
-[bumpversion]
-current_version = 5.3.1
-commit = True
-tag = True
-tag_name = {new_version}
-
[bumpversion:file:setup.py]
[bumpversion:file:natsort/_version.py]
@@ -49,21 +49,21 @@ tag_name = {new_version}
[tool:pytest]
flakes-ignore =
- natsort/compat/py23.py UndefinedName
- natsort/__init__.py UnusedImport
- natsort/compat/* UnusedImport
- docs/source/conf.py ALL
- test_natsort/test_natsort.py UnusedImport RedefinedWhileUnused
- test_natsort/test_locale_help.py UnusedImport RedefinedWhileUnused
- test_natsort/compat/* UnusedImport
-
-pep8ignore =
- natsort/ns_enum.py E126 E241 E123 E221
- test_natsort/test_*.py E501 E241 E221
- test_natsort/test_natsort_keygen.py E501 E241 E221 E701
- test_natsort/profile_natsorted.py ALL
- docs/source/conf.py ALL
+ natsort/compat/py23.py UndefinedName
+ natsort/__init__.py UnusedImport
+ natsort/compat/* UnusedImport
+ docs/source/conf.py ALL
+ test_natsort/test_natsort.py UnusedImport RedefinedWhileUnused
+ test_natsort/test_locale_help.py UnusedImport RedefinedWhileUnused
+ test_natsort/compat/* UnusedImport
+pep8ignore =
+ natsort/ns_enum.py E126 E241 E123 E221
+ test_natsort/test_*.py E501 E241 E221
+ test_natsort/test_natsort_keygen.py E501 E241 E221 E701
+ test_natsort/profile_natsorted.py ALL
+ docs/source/conf.py ALL
[flake8]
max-line-length = 160
ignore = E231,E302
+
diff --git a/setup.py b/setup.py
index e50690d..6d69e96 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from setuptools import setup, find_packages
setup(
name='natsort',
- version='5.3.1',
+ version='5.3.2',
packages=find_packages(),
install_requires=["argparse; python_version < '2.7'"],
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},