summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2018-11-18 14:53:46 -0800
committerSeth M Morton <seth.m.morton@gmail.com>2018-11-18 14:53:46 -0800
commit4e3bdddd58c874622431a4b9dc8ef86dfdef8d18 (patch)
tree05a86540a1ca37fd074b63b18d00fc5b59323fdb
parent00a1113cfc7b7cc89d6f8c6e4e70f9246017585f (diff)
downloadnatsort-4e3bdddd58c874622431a4b9dc8ef86dfdef8d18.tar.gz
Bump version: 5.4.1 → 5.5.05.5.0
-rw-r--r--CHANGELOG.rst2
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg7
-rw-r--r--setup.py2
5 files changed, 8 insertions, 7 deletions
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index 1f98935..0a053e8 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -1,4 +1,4 @@
-XX-XX-XXXX v. X.X.X
+11-18-2018 v. 5.5.0
+++++++++++++++++++
- Formally deprecated old or misleading APIs (issue #83)
diff --git a/docs/conf.py b/docs/conf.py
index 05c7aea..dc00018 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -57,7 +57,7 @@ copyright = u'2014, Seth M. Morton'
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = '5.4.1'
+release = '5.5.0'
# The short X.Y version.
version = '.'.join(release.split('.')[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index 200f9d2..00e2205 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -26,7 +26,7 @@ from natsort.utils import chain_functions
if float(sys.version[:3]) < 3:
from natsort.natsort import natcmp
-__version__ = "5.4.1"
+__version__ = "5.5.0"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index 72face2..3b44072 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 5.4.1
+current_version = 5.5.0
commit = True
tag = True
tag_name = {new_version}
@@ -12,7 +12,7 @@ description = Simple yet flexible natural sorting in Python.
long_description = file: README.rst
license = MIT
license_file = LICENSE
-classifiers =
+classifiers =
Development Status :: 5 - Production/Stable
Intended Audience :: Developers
Intended Audience :: Science/Research
@@ -55,7 +55,7 @@ max-line-length = 89
import-order-style = pycharm
doctests = True
max-complexity = 10
-exclude =
+exclude =
natsort.egg-info,
.tox,
.cache,
@@ -66,3 +66,4 @@ exclude =
docs,
.venv,
natsort/compat/py23.py
+
diff --git a/setup.py b/setup.py
index 7318d0b..48f453a 100644
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,7 @@ else:
setup(
name='natsort',
- version='5.4.1',
+ version='5.5.0',
packages=find_packages(),
install_requires=install_requires,
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},