diff options
author | Seth M Morton <seth.m.morton@gmail.com> | 2016-05-02 23:45:22 -0700 |
---|---|---|
committer | Seth M Morton <seth.m.morton@gmail.com> | 2016-05-02 23:45:22 -0700 |
commit | ccbc4263016b057db18dc224bdcefcdc3e0ec54b (patch) | |
tree | 7595ac09b7ad30897e4a1bc3fb93d733175debf2 | |
parent | 6df122afa36c24f30908f4b706d61a1ec97cadcd (diff) | |
download | natsort-ccbc4263016b057db18dc224bdcefcdc3e0ec54b.tar.gz |
Fixed testing bug with Python 2.6.
-rw-r--r-- | setup.py | 9 |
1 files changed, 6 insertions, 3 deletions
@@ -20,11 +20,14 @@ class PyTest(TestCommand): def run_tests(self): # import here, cause outside the eggs aren't loaded + if sys.version[:3] == '2.6': + flakes_pep8 = [] + else: + flakes_pep8 = ['--flakes', '--pep8'] import pytest - return pytest.main(['--cov', 'natsort', + return pytest.main(flakes_pep8 + + ['--cov', 'natsort', '--cov-report', 'term-missing', - '--flakes', - '--pep8', # '-s', # '--failed', # '-v', |