summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2019-11-19 14:34:57 -0800
committerSeth Morton <seth.m.morton@gmail.com>2019-11-19 14:59:49 -0800
commit05b14b0bb2dc21f2e2d091bc6ccc094413948840 (patch)
treedd9a00446ccae47ee8eba91c48357a2094bd26a2
parent6486a398a97e1073d590ca40c1130f7120dd34c9 (diff)
downloadnatsort-05b14b0bb2dc21f2e2d091bc6ccc094413948840.tar.gz
Clean up environment matrix
Only define environment variables when needed. The WITH_EXTRAS need not be set if empty.
-rw-r--r--.travis.yml11
1 files changed, 1 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index 737d3c5..9d992a1 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -10,9 +10,6 @@ python:
- 3.7
- 3.8
-# By default do not build "extras". Builds with "extras" will be included manually below.
-env: WITH_EXTRAS=""
-
# Explicitly include other jobs/configurations not defined by the above settings
jobs:
include:
@@ -33,7 +30,6 @@ jobs:
language: sh
os: osx
env:
- - WITH_EXTRAS=""
- TOXENV=py37
- PYENV_VERSION="3.7.1"
before_install:
@@ -44,9 +40,7 @@ jobs:
language: cpp
os: windows
filter_secrets: false
- env:
- - WITH_EXTRAS=""
- - TOXENV=py37
+ env: TOXENV=py37
before_install:
- choco install python --version 3.7.1
- export PATH="/c/Python37:/c/Python37/Scripts:$PATH"
@@ -62,13 +56,11 @@ jobs:
python: "3.7"
install: pip install black
script: black --quiet --check --diff
- env: [] # no environment variables needed.
- stage: code quality
name: "Static Analysis"
python: "3.7"
install: pip install flake8 flake8-import-order flake8-bugbear pep8-naming
script: flake8
- env: [] # no environment variables needed.
- stage: code quality
name: "Package Validation"
python: "3.7"
@@ -77,7 +69,6 @@ jobs:
- check-manifest --ignore ".github*,*.md,.coveragerc"
- python setup.py sdist
- twine check dist/*
- env: [] # no environment variables needed.
# The remainder of the code should be the same no matter the configuration/OS