summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2019-03-02 21:50:02 -0800
committerSeth Morton <seth.m.morton@gmail.com>2019-03-02 23:31:09 -0800
commitc3f6a7cc77f6cdad09434a85836ea0dda1e84476 (patch)
tree064926d287e611f3644392d44bf3e0d691004d61
parent0ffe15d96926c8e4266b842272f280d3b402b0cb (diff)
downloadnatsort-c3f6a7cc77f6cdad09434a85836ea0dda1e84476.tar.gz
Change header style from "##" to underline dashes
-rw-r--r--CHANGELOG.md132
1 files changed, 88 insertions, 44 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 09eaecf..1ba30a7 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,9 +1,11 @@
-## [Unreleased]
+[Unreleased]
+---
### Changed
- Update CHANGELOG format to style from https://keepachangelog.com/
-## [6.0.0] - 02-04-2019
+[6.0.0] - 02-04-2019
+---
### Changed
- Simply Travis-CI configuration ([@jdufresne](https://github.com/jdufresne), issue #88)
@@ -18,7 +20,8 @@
`index_versorted`) (issue #81)
- Remove `pipenv` as a dependency for building (issue #86)
-## [5.5.0] - 11-18-2018
+[5.5.0] - 11-18-2018
+---
### Added
- `CHANGELOG.rst` to the top-level of the repository (issue #85)
@@ -34,7 +37,8 @@
### Fixed
- Add back support for very old versions of setuptools (issue #84)
-## [5.4.1] - 09-09-2018
+[5.4.1] - 09-09-2018
+---
### Changed
- Code format and quality checking infrastructure (issue #68)
@@ -42,7 +46,8 @@
### Fixed
- Error in a newly added test (issues #65, #67)
-## [5.4.0] - 09-06-2018
+[5.4.0] - 09-06-2018
+---
### Changed
- Re-expose `natsort_key` as "public" and remove the associated `DepricationWarning`
@@ -50,7 +55,8 @@
- Refactor tests (issue #66)
- Bump allowed [`fastnumbers`](https://github.com/SethMMorton/fastnumbers) version
-## [5.3.3] - 07-07-2018
+[5.3.3] - 07-07-2018
+---
### Added
- Enable Python 3.7 support in Travis-CI (issue #61)
@@ -62,14 +68,16 @@
- `StopIteration` error in the testing code
-## [5.3.2] - 05-17-2018
+[5.3.2] - 05-17-2018
+---
### Fixed
- Bug that prevented install on old versions of `setuptools` (issues #55, #56)
- Revert layout from `src/natsort/` back to `natsort/` to make user
testing simpler (issues #57, #58)
-## [5.3.1] - 05-14-2018
+[5.3.1] - 05-14-2018
+---
### Added
- [`bumpversion`](https://github.com/c4urself/bump2version) infrastructure
@@ -80,7 +88,8 @@
- Move to defining dependencies with `Pipfile`
- Development layout is now `src/natsort/` instead of `natsort/`
-## [5.3.0] - 04-20-2018
+[5.3.0] - 04-20-2018
+---
### Added
- Ability to consider unicode-decimal numbers as numbers (issues #52, #54)
@@ -89,19 +98,22 @@
- Bug in assessing [`fastnumbers`](https://github.com/SethMMorton/fastnumbers)
version at import-time ([@hholzgra](https://github.com/hholzgra), issues #51, #53)
-## [5.2.0] - 02-14-2018
+[5.2.0] - 02-14-2018
+---
### Added
- `ns.NUMAFTER` to cause numbers to be placed after non-numbers (issues #48, #49)
- `natcmp` function (Python 2 only) ([@rinslow](https://github.com/rinslow), issue #47)
-## [5.1.1] - 11-11-2017
+[5.1.1] - 11-11-2017
+---
### Added
- Additional unicode number support for Python 3.7
- Information on how to install and test (issue #46)
-## [5.1.0] - 08-19-2017
+[5.1.0] - 08-19-2017
+---
### Changed
- All Unicode input is now normalized (issue #44, #45)
@@ -110,12 +122,14 @@
- `StopIteration` warning on Python 3.6+
([@lykinsbd](https://github.com/lykinsbd), issues #42, #43)
-## [5.0.3] - 04-30-2017
+[5.0.3] - 04-30-2017
+---
- Improved development infrastructure
- Migrated documentation to ReadTheDocs
-## [5.0.2] - 01-02-2017
+[5.0.2] - 01-02-2017
+---
### Added
- Additional unicode number support for Python 3.6
@@ -125,7 +139,8 @@
- Renamed several internal functions and variables to improve clarity
- Improved documentation examples
-## [5.0.1] - 06-04-2016
+[5.0.1] - 06-04-2016
+---
### Added
- The `ns` enum attributes can now be imported from the top-level namespace
@@ -134,7 +149,8 @@
- Bug with the `from natsort import *` mechanism
- Bug with using `natsort` with `python -OO` (issues #38, #39)
-## [5.0.0] - 05-08-2016
+[5.0.0] - 05-08-2016
+---
### Added
- `chain_functions` function for convenience in creating
@@ -156,7 +172,8 @@
- `ns.TYPESAFE` option as it is now always on (due to a new
iterator-based algorithm, the typesafe function is now cheap)
-## [4.0.4] - 11-01-2015
+[4.0.4] - 11-01-2015
+---
### Changed
- Improved coverage of unit tests
@@ -165,12 +182,14 @@
### Fixed
- Compatibility issues with Python 3.5
-## [4.0.3] - 06-25-2015
+[4.0.3] - 06-25-2015
+---
### Fixed
- Bad install on last release (sorry guys!) (issue #30)
-## [4.0.2] - 06-24-2015
+[4.0.2] - 06-24-2015
+---
### Changed
- Consolidated under-the-hood compatibility functionality
@@ -179,12 +198,14 @@
- Python 2.6 and Python 3.2 compatibility. Unit testing is now
performed for these versions ([@dpetzold](https://github.com/dpetzold), issue #29)
-## [4.0.1] - 06-04-2015
+[4.0.1] - 06-04-2015
+---
### Added
- Support for sorting NaN by internally converting to -Infinity or +Infinity (issue #27)
-## [4.0.0] - 05-17-2015
+[4.0.0] - 05-17-2015
+---
### Changed
- Made default behavior of `natsort` search for unsigned ints,
@@ -195,7 +216,8 @@
underlying locale library is broken (issue #34))
- Greatly improved all unit tests by adding the `hypothesis` library
-## [3.5.6] - 04-06-2015
+[3.5.6] - 04-06-2015
+---
### Added
- `UNGROUPLETTERS` algorithm to get the case-grouping behavior of
@@ -203,7 +225,8 @@
- Convenience functions `decoder`, `as_ascii`, and `as_utf8` for
dealing with bytes types
-## [3.5.5] - 04-04-2015
+[3.5.5] - 04-04-2015
+---
### Added
- `realsorted` and `index_realsorted` functions for forward-compatibility with >= 4.0.0
@@ -211,13 +234,15 @@
### Changed
- Made explanation of when to use `TYPESAFE` more clear in the docs
-## [3.5.4] - 04-02-2015
+[3.5.4] - 04-02-2015
+---
### Fixed
- Bug where a `TypeError` was raised if a string containing a leading
number was sorted with alpha-only strings when `LOCALE` is used (issue #22)
-## [3.5.3] - 03-26-2015
+[3.5.3] - 03-26-2015
+---
### Changed
- Documentation updates to better describe locale bug, and illustrate
@@ -228,12 +253,14 @@
- Bug where `--reverse-filter` option in shell script was not
getting checked for correctness
-## [3.5.2] - 01-13-2015
+[3.5.2] - 01-13-2015
+---
### Added
- A `pathlib.Path` object is converted to a `str` if `ns.PATH` is enabled (issue #16)
-## [3.5.1] - 09-25-2014
+[3.5.1] - 09-25-2014
+---
### Changed
- Refactored modules so that only the public API was in `natsort.py` and `ns_enum.py`
@@ -243,7 +270,8 @@
- Bug that caused list/tuples to fail when using `ns.LOWECASEFIRST`
or `ns.IGNORECASE` (issue #15)
-## [3.5.0] - 09-02-2014
+[3.5.0] - 09-02-2014
+---
### Added
- `alg` argument to the `natsort` functions. This argument
@@ -258,7 +286,8 @@
allows `natsort` to perform true "human sorting" (issue #14)
- Locale functionality to the shell script
-## [3.4.1] - 08-12-2014
+[3.4.1] - 08-12-2014
+---
### Changed
- `natsort` will now use the [`fastnumbers`](https://github.com/SethMMorton/fastnumbers)
@@ -267,7 +296,8 @@
- Made documentation point to more `natsort` resources, and also added a
new example in the examples section
-## [3.4.0] - 07-19-2014
+[3.4.0] - 07-19-2014
+---
### Added
- `natsort_keygen` function that will generate a wrapped version
@@ -296,7 +326,8 @@
- Bug that caused user's options to the 'natsort_key' to not be
passed on to recursive calls of 'natsort_key' (issue #12)
-## [3.3.0] - 06-28-2014
+[3.3.0] - 06-28-2014
+---
### Added
- `versorted` method for more convenient sorting of versions (issue #11)
@@ -310,13 +341,15 @@
- Made docstrings for public functions mirror the README API
- Connected `natsort` development to Travis-CI to help ensure quality releases
-## [3.2.1] - 06-20-2014
+[3.2.1] - 06-20-2014
+---
### Fixed
- Re-"Fixed" unorderable types issue on Python 3.x - this workaround
is for when the problem occurs in the middle of the string (issue #7 again)
-## [3.2.0] - 05-07-2014
+[3.2.0] - 05-07-2014
+---
### Fixed
- "Fixed" unorderable types issue on Python 3.x with a workaround that
@@ -327,13 +360,15 @@
- Now explicitly excluding `__pycache__` from releases by adding a prune statement
to MANIFEST.in
-## [3.1.2] - 05-05-2014
+[3.1.2] - 05-05-2014
+---
### Added
- `setup.cfg` to support universal wheels (issue #6)
- Python 3.0 and Python 3.1 as requiring the argparse module
-## [3.1.1] - 03-01-2014
+[3.1.1] - 03-01-2014
+---
### Added
- Ability to sort lists of lists (issue #5)
@@ -341,7 +376,8 @@
### Changed
- Cleaned up import statements
-## [3.1.0] - 01-20-2014
+[3.1.0] - 01-20-2014
+---
### Added
- `signed` and `exp` options to allow finer tuning of the sorting
@@ -362,7 +398,8 @@
- The shell script filesystem-based options because these can be achieved better though
a pipeline by which to filter
-## [3.0.2] - 10-01-2013
+[3.0.2] - 10-01-2013
+---
### Changed
- Made float, int, and digit searching algorithms all share the same base function
@@ -371,7 +408,8 @@ a pipeline by which to filter
### Fixed
- Outdated comments
-## [3.0.1] - 8-15-2013
+[3.0.1] - 8-15-2013
+---
### Added
- Support for unicode strings (issue #2)
@@ -382,7 +420,8 @@ a pipeline by which to filter
### Removed
- Extraneous `string2int` function
-## [3.0.0] - 7-13-2013
+[3.0.0] - 7-13-2013
+---
### Added
- A `number_type` argument to the sorting functions to specify how liberal to be when
@@ -391,7 +430,8 @@ a pipeline by which to filter
### Changed
- Reworked the documentation
-## [2.2.0] - 6-25-2013
+[2.2.0] - 6-25-2013
+---
### Added
- `key` attribute to `natsorted` and `index_natsorted` so that it mimics the functionality
@@ -399,21 +439,24 @@ a pipeline by which to filter
- Tests to reflect the new functionality, as well as tests demonstrating how to get similar
functionality using `natsort_key`
-## [2.1.0] - 12-5-2012
+[2.1.0] - 12-5-2012
+---
### Changed
- Reorganized package
- Now using a platform independent shell script generator (`entry_points` from distribute)
- Can now execute `natsort` from command line with `python -m natsort` as well
-## [2.0.2] - 11-30-2012
+[2.0.2] - 11-30-2012
+---
### Added
- The use_2to3 option to `setup.py`
- Include `distribute_setup.py` to the distribution
- Dependency to the `argparse` module (for python2.6)
-## [2.0.1] - 11-21-2012
+[2.0.1] - 11-21-2012
+---
### Added
- Tests into the natsort.py file iteself
@@ -421,7 +464,8 @@ a pipeline by which to filter
### Changed
- Reorganized directory structure
-## [2.0.0] - 11-16-2012
+[2.0.0] - 11-16-2012
+---
### Added
- Better README documentation