summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2018-11-18 19:39:57 -0800
committerSeth M Morton <seth.m.morton@gmail.com>2018-11-18 19:40:12 -0800
commit78ad1f24a69a9ef0059ac088fa6e203ab431094b (patch)
treec721c10c46572db0fca1c436401b3221179fe728
parent0e4e5919abe92c3993414ee67b4893d872a2d20a (diff)
downloadnatsort-78ad1f24a69a9ef0059ac088fa6e203ab431094b.tar.gz
Remove extra files from sdist
This was done by shortening the MANIFEST.in. The check-manifest evaluations have been moved from the tox environment "release" to "flake8" so that errors are caught earlier.
-rw-r--r--MANIFEST.in13
-rw-r--r--tox.ini7
2 files changed, 6 insertions, 14 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index df955b7..c385901 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,18 +1,9 @@
include LICENSE
-include CODE_OF_CONDUCT.md
-include CONTRIBUTING.md
-include *.sh
-include *.rst
+include CHANGELOG.rst
+include clean.sh
include dev-requirements.txt
-include setup.py
-include setup.cfg
include tox.ini
-include .travis.yml
-include .coveragerc
-include .gitignore
-include .bumpversion.cfg
graft docs
graft natsort
graft tests
global-exclude *.py[cod] __pycache__ *.so
-prune .github
diff --git a/tox.ini b/tox.ini
index 0e1e6ff..43bd93f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -37,7 +37,10 @@ deps =
flake8-import-order
flake8-bugbear
pep8-naming
-commands = flake8
+ check-manifest
+commands =
+ flake8
+ check-manifest --ignore ".github*,*.md,.coveragerc"
skip_install = true
# Build documentation.
@@ -53,9 +56,7 @@ skip_install = true
[testenv:release]
deps =
twine
- check-manifest
commands =
- check-manifest
{envpython} setup.py sdist bdist_wheel
twine upload dist/*
skip_install = true