summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2019-02-26 19:49:09 -0800
committerSeth Morton <seth.m.morton@gmail.com>2019-02-26 19:49:09 -0800
commit47cb257def542a694049cb32044041547f7bae2f (patch)
treecb2ddf28832ccd5769a2f78daa750ec018920edb
parentdef1269e3437185d9200c451a0f16b8fd55c2fc8 (diff)
downloadnatsort-47cb257def542a694049cb32044041547f7bae2f.tar.gz
Reorganize/comment Travis-CI configuration
-rw-r--r--.travis.yml26
1 files changed, 18 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index 9acf0f1..8e31c5c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -12,8 +12,23 @@ python:
# By default do not build "extras". Builds with "extras" will be included manually below.
env: WITH_EXTRAS=""
+# Explicitly include other jobs/configurations not defined by the above settings
jobs:
include:
+
+ # This "code-quality" stage does static analysis and formatting checks.
+ # Platform- and Python-version-independent.
+ - stage: code-quality
+ python: "3.6"
+ install: pip install flake8 flake8-import-order flake8-bugbear pep8-naming twine check-manifest
+ script:
+ - flake8
+ - check-manifest --ignore ".github*,*.md,.coveragerc"
+ - python setup.py sdist
+ - twine check dist/*
+
+ # For Python 2.7 and 3.7, do some extra configurations.
+ # Linux with both "icu" and "fastnumbers"
- python: "2.7"
env: WITH_EXTRAS="fast,icu"
addons:
@@ -30,14 +45,9 @@ jobs:
- libicu-dev
- language-pack-de
- language-pack-en
- - stage: code-quality
- python: "3.6"
- install: pip install flake8 flake8-import-order flake8-bugbear pep8-naming twine check-manifest
- script:
- - flake8
- - check-manifest --ignore ".github*,*.md,.coveragerc"
- - python setup.py sdist
- - twine check dist/*
+
+
+# The remainder of the code should be the same no matter the configuration/OS
install:
- pip install -U pip