summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@alastairs-place.net>2014-04-28 17:26:45 +0100
committerAlastair Houghton <alastair@alastairs-place.net>2014-04-28 17:26:45 +0100
commit4a10eb15f2a7d8608becbae454732e6b3a54f61a (patch)
tree05ccf0d407372ef6cf83bff271fab11774ed709e
parentbfaa57bca41f32413825abfb5e949e452ec7f3a0 (diff)
downloadnetifaces-git-4a10eb15f2a7d8608becbae454732e6b3a54f61a.tar.gz
Fixed a final Python 3K problem.
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ee7f408..cbbf92f 100644
--- a/setup.py
+++ b/setup.py
@@ -99,7 +99,7 @@ class my_build_ext(build_ext):
# things to test for features is slow
cache_file = os.path.join(self.build_temp, 'config.cache')
if os.path.exists(cache_file):
- myfile = open(cache_file, 'r')
+ myfile = open(cache_file, 'rb')
try:
results = pickle.load(myfile)
finally: