summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@alastairs-place.net>2014-04-28 17:19:56 +0100
committerAlastair Houghton <alastair@alastairs-place.net>2014-04-28 17:19:56 +0100
commitbfaa57bca41f32413825abfb5e949e452ec7f3a0 (patch)
tree155ecb5424cd3c588e1ce0a2ec6c040c7f0d8e34
parentf87507200874cfafda149cee4c7cdb8f784320b3 (diff)
downloadnetifaces-git-bfaa57bca41f32413825abfb5e949e452ec7f3a0.tar.gz
More Python 3K compatibility.
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 714c127..ee7f408 100644
--- a/setup.py
+++ b/setup.py
@@ -385,8 +385,8 @@ class my_build_ext(build_ext):
results['have_sockaddrs'] = result
- # Save the results to our config.cache file
- myfile = open(cache_file, 'w')
+ # Save the results to our config.cache file
+ myfile = open(cache_file, 'wb')
try:
pickle.dump(results, myfile)
finally: