summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2022-08-18 15:11:17 -0500
committerGitHub <noreply@github.com>2022-08-18 15:11:17 -0500
commitd8d04e76f4db5c618e32c903266d09aec912017d (patch)
tree058fa49668bde02af11887138c73b413e7afa609
parent70c9c7facdbca90ea3f8fd1bcd9652168cd5642c (diff)
parenta6894abb1400b052e40651eb2bd3da896b6ef350 (diff)
downloadnumpy-d8d04e76f4db5c618e32c903266d09aec912017d.tar.gz
Merge pull request #22148 from charris/add-python310-to-classifiers
MAINT: Update setup.py for Python 3.11.
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 353b6c096..3aa7504b0 100755
--- a/setup.py
+++ b/setup.py
@@ -66,7 +66,7 @@ MAJOR, MINOR, MICRO = _V_MATCH.groups()
VERSION = '{}.{}.{}'.format(MAJOR, MINOR, MICRO)
# The first version not in the `Programming Language :: Python :: ...` classifiers above
-if sys.version_info >= (3, 11):
+if sys.version_info >= (3, 12):
fmt = "NumPy {} may not yet support Python {}.{}."
warnings.warn(
fmt.format(VERSION, *sys.version_info[:2]),
@@ -112,6 +112,7 @@ Programming Language :: Python :: 3
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
Programming Language :: Python :: 3.10
+Programming Language :: Python :: 3.11
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: Implementation :: CPython
Topic :: Software Development