summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Huot <JonathanHuot@users.noreply.github.com>2018-03-18 10:59:11 +0100
committerPieter Ennes <pieter@ennes.nl>2018-03-18 09:59:11 +0000
commitf398fdb7b0ac7b0aa11408d11a4358524360ac77 (patch)
tree688f55ba0ff759dd250eb326105992a363ce1c84
parent70b5827566dc3c0dd8f05cfbb8311b905f7a7254 (diff)
downloadoauthlib-f398fdb7b0ac7b0aa11408d11a4358524360ac77.tar.gz
Fix ReadTheDocs build (#521)
-rw-r--r--docs/conf.py3
-rw-r--r--tox.ini6
2 files changed, 6 insertions, 3 deletions
diff --git a/docs/conf.py b/docs/conf.py
index b1ca34d..017f686 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -14,8 +14,6 @@
import os
import sys
-from oauthlib import __version__ as v
-
# If extensions (or modules to document with autodoc) are in another directory,
# add these directories to sys.path here. If the directory is relative to the
# documentation root, use os.path.abspath to make it absolute, like shown here.
@@ -51,6 +49,7 @@ copyright = u'2012, Idan Gazit and the Python Community'
#
# The short X.Y version.
+from oauthlib import __version__ as v
version = v[:3]
# The full version, including alpha/beta/rc tags.
release = v
diff --git a/tox.ini b/tox.ini
index 2546bee..3dded41 100644
--- a/tox.ini
+++ b/tox.ini
@@ -10,8 +10,12 @@ commands=nosetests --with-coverage --cover-erase --cover-package=oauthlib -w tes
deps=unittest2
{[testenv]deps}
+# tox -e docs to mimick readthedocs build.
+# as of today, RTD is using python2.7 and doesn't run "setup.py install"
[testenv:docs]
+basepython=python2.7
+skipsdist=True
deps=sphinx
changedir=docs
whitelist_externals=make
-commands=make html
+commands=make clean html