summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorjason <jason@zzq.org>2021-02-08 14:22:26 -0700
committerAsif Saif Uddin <auvipy@gmail.com>2021-02-10 19:05:47 +0600
commit637c8945f2ba1481927478db7d1fa09de43c265b (patch)
tree67e638487090acc01de8ba24f8698a01567c2e48 /setup.py
parentd54965b86ce4ede956db70baff0b3d5e9182a007 (diff)
downloadoauthlib-637c8945f2ba1481927478db7d1fa09de43c265b.tar.gz
Remove python 3.5 support; add python 3.8 support
- Python 3.5 has reached end-of-life. - Add support for Python 3.8 - Move dist to bionic (xenial is EOL in April) - Upgrade pip in travis.yml's `before_install`. this should install a wheel for pyca/cryptography - Install rust for pypy builds. It is a requirement for cryptography as no pypy wheels exist.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 0babb45..fed5814 100755
--- a/setup.py
+++ b/setup.py
@@ -34,7 +34,7 @@ setup(
platforms='any',
license='BSD',
packages=find_packages(exclude=('docs', 'tests', 'tests.*')),
- python_requires='>=3.5',
+ python_requires='>=3.6',
extras_require={
'rsa': rsa_require,
'signedtoken': signedtoken_require,
@@ -51,9 +51,9 @@ setup(
'Operating System :: POSIX :: Linux',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3 :: Only',
'Programming Language :: Python :: Implementation',
'Programming Language :: Python :: Implementation :: CPython',