summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChangBo Guo(gcb) <eric.guo@easystack.cn>2016-02-19 18:52:36 +0800
committerChangBo Guo(gcb) <eric.guo@easystack.cn>2016-02-19 19:03:06 +0800
commit54d58a77583468b51e6843cd1b3d6ef730da44f4 (patch)
treea2583fee8a87621281099de9eabee4264a2c9f99
parent14507498c845daea4aa7808f1921dc02e9f9ef70 (diff)
downloadosprofiler-54d58a77583468b51e6843cd1b3d6ef730da44f4.tar.gz
Remove flake8 ignore list in tox.ini1.2.0
H703 doesn't exist in hacking>=0.10.2, so remove it. Fix E126 violations and remove E126. Change-Id: I727282e4e7f276318f3cdd50d885941ab8b4ff49
-rw-r--r--osprofiler/opts.py28
-rw-r--r--tox.ini1
2 files changed, 14 insertions, 15 deletions
diff --git a/osprofiler/opts.py b/osprofiler/opts.py
index c37624d..c7ecf2d 100644
--- a/osprofiler/opts.py
+++ b/osprofiler/opts.py
@@ -23,19 +23,19 @@ __all__ = [
]
_profiler_opt_group = cfg.OptGroup(
- "profiler",
- title="OpenStack cross-service profiling",
- help="""
+ "profiler",
+ title="OpenStack cross-service profiling",
+ help="""
OSprofiler library allows to trace requests going through various OpenStack
services and create the accumulated report of what time was spent on each
request processing step.""")
_enabled_opt = cfg.BoolOpt(
- "enabled",
- default=False,
- deprecated_group="profiler",
- deprecated_name="profiler_enabled",
- help="""
+ "enabled",
+ default=False,
+ deprecated_group="profiler",
+ deprecated_name="profiler_enabled",
+ help="""
Enables the profiling for all services on this node. Default value is False
(fully disable the profiling feature).
@@ -48,9 +48,9 @@ will be empty.
""")
_trace_sqlalchemy_opt = cfg.BoolOpt(
- "trace_sqlalchemy",
- default=False,
- help="""
+ "trace_sqlalchemy",
+ default=False,
+ help="""
Enables SQL requests profiling in services. Default value is False (SQL
requests won't be traced).
@@ -64,9 +64,9 @@ way.
""")
_hmac_keys_opt = cfg.StrOpt(
- "hmac_keys",
- default="SECRET_KEY",
- help="""
+ "hmac_keys",
+ default="SECRET_KEY",
+ help="""
Secret key(s) to use for encrypting context data for performance profiling.
This string value should have the following format: <key1>[,<key2>,...<keyn>],
where each key is some random string. A user who triggers the profiling via
diff --git a/tox.ini b/tox.ini
index fbcd0e2..12e18de 100644
--- a/tox.ini
+++ b/tox.ini
@@ -31,7 +31,6 @@ changedir = doc/source
commands = make html
[flake8]
-ignore = E126,H703
show-source = true
builtins = _
exclude=.venv,.git,.tox,dist,doc,*lib/python*,*egg,tools,setup.py