summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini24
1 files changed, 10 insertions, 14 deletions
diff --git a/tox.ini b/tox.ini
index 8601286..aee1fcc 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,9 +1,12 @@
[tox]
-minversion = 2.0
-skipsdist = True
-envlist = py27,py37,pep8
+minversion = 3.1.0
+# Needed to create ChangeLog for docs building
+skipsdist = False
+envlist = py37,pep8
+ignore_basepython_conflict = True
[testenv]
+basepython = python3
setenv = VIRTUAL_ENV={envdir}
LANG=en_US.UTF-8
LANGUAGE=en_US:en
@@ -12,13 +15,11 @@ deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://opendev.org/openstack/requirements/raw/branch/master/upper-constraints.txt}
-r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
-install_command = pip install -U {opts} {packages}
usedevelop = True
commands = stestr run --slowest {posargs}
distribute = false
[testenv:functional]
-basepython = python2.7
setenv = {[testenv]setenv}
OS_TEST_PATH=./osprofiler/tests/functional
deps =
@@ -28,10 +29,10 @@ deps =
[testenv:functional-py36]
basepython = python3.6
setenv = {[testenv:functional]setenv}
-deps = {[testenv:functional]deps}
+deps =
+ {[testenv:functional]deps}
[testenv:pep8]
-basepython = python3
commands =
flake8
# Run security linter
@@ -39,11 +40,9 @@ commands =
distribute = false
[testenv:venv]
-basepython = python3
commands = {posargs}
[testenv:cover]
-basepython = python3
setenv =
PYTHON=coverage run --source osprofiler --parallel-mode
commands =
@@ -53,11 +52,10 @@ commands =
coverage xml -o cover/coverage.xml
[testenv:docs]
-basepython = python3
-commands = python setup.py build_sphinx
+commands =
+ sphinx-build -W --keep-going -b html -d doc/build/doctrees doc/source doc/build/html
[testenv:bandit]
-basepython = python3
commands = bandit -r osprofiler -n5
[flake8]
@@ -69,11 +67,9 @@ exclude=.venv,.git,.tox,dist,doc,*lib/python*,*egg,tools,setup.py,build,releasen
local-check-factory = osprofiler.hacking.checks.factory
[testenv:releasenotes]
-basepython = python3
commands = sphinx-build -a -E -W -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html
[testenv:lower-constraints]
-basepython = python3
deps =
-c{toxinidir}/lower-constraints.txt
-r{toxinidir}/test-requirements.txt