summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Collins <elic@assurancetechnologies.com>2019-11-12 13:47:36 -0500
committerEli Collins <elic@assurancetechnologies.com>2019-11-12 13:47:36 -0500
commit0e64c30524b0bf3e98bfe90cb3ecd3259937a3ae (patch)
tree25b4c0a901fb86ab4c6a637b153b37df1113c993
parent346f6994e4ddb30fbb85f922e2745cb9f58a217d (diff)
downloadpasslib-0e64c30524b0bf3e98bfe90cb3ecd3259937a3ae.tar.gz
docs: updated build dependancies
-rw-r--r--docs/conf.py4
-rw-r--r--docs/history/1.7.rst4
-rw-r--r--docs/install.rst7
-rw-r--r--docs/requirements.txt5
-rw-r--r--setup.py13
5 files changed, 22 insertions, 11 deletions
diff --git a/docs/conf.py b/docs/conf.py
index ab34062..2740e94 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -51,7 +51,7 @@ import cloud_sptheme as csp
#=============================================================================
# If your documentation needs a minimal Sphinx version, state it here.
-needs_sphinx = '1.4'
+needs_sphinx = '1.6'
# Add any Sphinx extension module names here, as strings. They can be extensions
# coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
@@ -205,7 +205,7 @@ if csp.is_cloud_theme(html_theme):
)
# Add any paths that contain custom themes here, relative to this directory.
-html_theme_path = [csp.get_theme_dir()]
+# html_theme_path = []
# The name for this set of Sphinx documents. If None, it defaults to
# "<project> v<release> documentation".
diff --git a/docs/history/1.7.rst b/docs/history/1.7.rst
index 4b066fb..7027f18 100644
--- a/docs/history/1.7.rst
+++ b/docs/history/1.7.rst
@@ -56,7 +56,9 @@ Other Changes
:class:`argon2`: Now throws helpful error if "argon2" package is actually an incompatible
or supported version of argon2_cffi (:issue:`99`).
-* **documentation**: Various updates & corrections.
+* **documentation**: Various updates & corrections.
+ building the documentation now requires Sphinx 1.6 or newer.
+
**1.7.1** (2017-1-30)
=====================
diff --git a/docs/install.rst b/docs/install.rst
index 00cab65..7af15ff 100644
--- a/docs/install.rst
+++ b/docs/install.rst
@@ -138,9 +138,8 @@ online at `<https://passlib.readthedocs.io>`_.
If you wish to generate your own copy of the documentation,
you will need to:
-1. Install `Sphinx <http://sphinx.pocoo.org/>`_ (1.4 or newer)
-2. Install the `Cloud Sphinx Theme <http://packages.python.org/cloud_sptheme>`_ (1.9.2 or newer).
-3. Download the Passlib source
-4. From the Passlib source directory, run :samp:`python setup.py build_sphinx`.
+1. Download the Passlib source, extract it, and ``cd`` into the source directory.
+2. Install all the dependencies required via ``pip install -e .[build_docs]``
+3. Run :samp:`python setup.py build_sphinx`.
5. Once Sphinx completes its run, point a web browser to the file at :samp:`{SOURCE}/build/sphinx/html/index.html`
to access the Passlib documentation in html format.
diff --git a/docs/requirements.txt b/docs/requirements.txt
index 2ce7120..5afb30c 100644
--- a/docs/requirements.txt
+++ b/docs/requirements.txt
@@ -1,5 +1,2 @@
-# NOTE: switched to custom branch until https://github.com/dreamhost/sphinxcontrib-fulltoc/issues/10 is fixed
-## sphinxcontrib-fulltoc
-git+https://github.com/eli-collins/sphinxcontrib-fulltoc.git
-
+sphinxcontrib-fulltoc
hg+https://bitbucket.org/ecollins/cloud_sptheme
diff --git a/setup.py b/setup.py
index 1d6d421..0f56134 100644
--- a/setup.py
+++ b/setup.py
@@ -46,9 +46,22 @@ opts = dict(
# NOTE: 'download_url' set below
extras_require={
+ # extras w/ recommended library for argon2 backend
"argon2": "argon2_cffi>=18.2.0",
+
+ # extras w/ recommended library for bcrypt backend (if not present on host)
"bcrypt": "bcrypt>=3.1.0",
+
+ # extras to make (full) use of "passlib.totp" module
"totp": "cryptography",
+
+ # extras required to build passlib docs
+ # TODO: automate way to sync this w/ "./docs/requirements.txt"
+ "build_docs": [
+ "sphinx>=1.6",
+ "sphinxcontrib-fulltoc>=1.2.0",
+ "cloud_sptheme>=1.10.0",
+ ],
},
#==================================================================