summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Dent <cdent@anticdent.org>2018-10-23 16:01:34 +0100
committerChris Dent <cdent@anticdent.org>2018-10-23 16:01:34 +0100
commit95efbbf0137de2f0e472ca12d60cfe242c01ec27 (patch)
treec417886363668b1163d93e91655d11603928482a
parent5ee64fa8d48d6d853e30f57d80e271184ceee993 (diff)
downloadpaste-git-95efbbf0137de2f0e472ca12d60cfe242c01ec27.tar.gz
Update README and setup.py for new location
pythonpaste.org no longer exists so we need to remove those links
-rw-r--r--README.rst21
-rw-r--r--setup.py4
2 files changed, 12 insertions, 13 deletions
diff --git a/README.rst b/README.rst
index 3b2ab8f..a856473 100644
--- a/README.rst
+++ b/README.rst
@@ -1,3 +1,8 @@
+
+*Paste is in maintenance mode and recently moved from bitbucket to github.
+Patches are accepted to keep it on life support, but for the most part, please
+consider using other options.*
+
Paste provides several pieces of "middleware" (or filters) that can be nested
to build web applications. Each piece of middleware uses the WSGI (`PEP 333`_)
interface, and should be compatible with other middleware based on those
@@ -5,19 +10,14 @@ interfaces.
.. _PEP 333: http://www.python.org/dev/peps/pep-0333.html
-* `Paste project at Bitbucket (source code, bug tracker)
- <https://bitbucket.org/ianb/paste/>`_
+* `Paste project at GitHub (source code, bug tracker)
+ <https://github.com/cdent/paste/>`_
* `Paste on the Python Cheeseshop (PyPI)
<https://pypi.python.org/pypi/Paste>`_
-* `Paste documentation
- <http://pythonpaste.org/>`_
See also:
-* `PasteDeploy <http://pythonpaste.org/deploy/>`_
-* `PasteScript <http://pythonpaste.org/script/>`_
-* `WebTest <http://webtest.pythonpaste.org/>`_
-* `WebOb <http://docs.webob.org/>`_
+* `WebOb <https://docs.pylonsproject.org/projects/webob>`_
Includes these features...
@@ -103,7 +103,4 @@ Other Tools
* A class for generating and traversing URLs, and creating associated
HTML code, in ``paste.url``
-The official development repo is at https://bitbucket.org/ianb/paste.
-
-For the latest changes see the `news file
-<http://pythonpaste.org/news.html>`_.
+The official development repo is at https://github.com/cdent/paste.
diff --git a/setup.py b/setup.py
index 28ca0df..786e72f 100644
--- a/setup.py
+++ b/setup.py
@@ -7,6 +7,8 @@
# the SCM (Mercurial): update MANIFEST.in if needed
# - update changelog: docs/news.txt
#
+# TODO(cdent): Update for github.
+#
# - hg ci
# - hg tag VERSION
# - hg push
@@ -49,7 +51,7 @@ setup(name="Paste",
keywords='web application server wsgi',
author="Ian Bicking",
author_email="ianb@colorstudy.com",
- url="http://pythonpaste.org",
+ url="https://pypi.org/project/Paste/",
license="MIT",
packages=find_packages(exclude=['ez_setup', 'examples', 'packages', 'tests*']),
package_data=finddata.find_package_data(